Bug 165379 - proxy installer is installing rhns before rhn-apache, causes warning
proxy installer is installing rhns before rhn-apache, causes warning
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Rel-Eng (Show other bugs)
rhn400
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Beth Nackashi
:
Depends On:
Blocks: 168311
  Show dependency treegraph
 
Reported: 2005-08-08 14:17 EDT by Beth Nackashi
Modified: 2007-04-18 13:30 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn401
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-12 12:48:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proxy installation rhn_check -vvv output (4.97 KB, text/plain)
2005-08-08 14:17 EDT, Beth Nackashi
no flags Details

  None (edit)
Description Beth Nackashi 2005-08-08 14:17:23 EDT
Description of problem:
Proxy installer is installing rhns before rhn-apache.  This causes a warning to
be output to stdout because rhns requires the apache group that rhn-apache creates.

Version-Release number of selected component (if applicable):
up2date-4.4.36-3
rhel 3 u5 AS
i686

How reproducible:
always

Steps to Reproduce:
1.  install a proxy on RHEL 3 U5 AS or RHEL 4 U1 AS box using up2date-4.4.36-x
2. 
3.
  
Actual results:
1. "warning: group apache does not exist - using root" when preparing to install
rhns
2.  rhns is installed with group root
3.  rhn-apache is installed after rhns

Expected results:
1.  rhn-apache is installed before rhns
2.  rhns can successfully be installed with group apache

Additional info:
This will need to be cloned for rhel 4 U2 up2date as well.
Comment 1 Beth Nackashi 2005-08-08 14:17:23 EDT
Created attachment 117551 [details]
proxy installation rhn_check -vvv output
Comment 2 Adrian Likins 2005-08-08 14:22:48 EDT
If anything, this is either a packaging bug, or an rpm bug, since the transaction
ordering is all done by librpm based on the package info. up2date doesn't
influence the package transaction ordering.
Comment 3 Todd Warner 2005-08-08 14:28:36 EDT
I think this is a jconnor bug... punting to him. This may be a misa bug.

Also... that "warning" is misleading. The code really *has* to be installed with
the apache group permissions. It's a warning according to RPM, but not to our
app-stack.
Comment 4 Adrian Likins 2005-08-08 14:34:29 EDT
when did this start happening?
what are the versions of rhns/rhn-apache/httpd/etc involved and where can I find
them?

what version of rpm?
Comment 5 Adrian Likins 2005-08-08 14:42:58 EDT
A quick glance at rhns-4.0.0-165.rhel4 doesn't show any requires on rhn-apache:

[root@test07 ~]# rpm -q --requires rhns
config(rhns) = 4.0.0-165.rhel4
python
rhnlib >= 1.8
rpm-python
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1


There doesn't seem to be anything in the packages to enfore an ordering, so this
looks to be a packaging bug.
Comment 6 Mihai Ibanescu 2005-08-09 16:19:21 EDT
SHould be fixed in rhns-4.0.0-173 and newer.
Comment 8 Beth Nackashi 2005-09-27 19:10:56 EDT
ok, well ... it seems to be working now anyway.  

[root@test07 log]# rpm -q rhns
rhns-4.0.0-185.rhel3
[root@test07 log]# rpm -q up2date
up2date-4.4.44-3
Comment 10 Beth Nackashi 2005-10-11 19:42:13 EDT
reverified with 
[root@test07 ~]# rpm -q rhns
rhns-4.0.0-186.rhel4
[root@test07 ~]# rpm -q up2date
up2date-4.4.50-4
Comment 11 Beth Nackashi 2005-10-12 12:48:33 EDT
verified these packages exist in prod:
rhns-4.0.0-186.rhel4
up2date-4.4.50-4

moving to CLOSED.

Note You need to log in before you can comment on or make changes to this bug.