Bug 165394 - "Recent Documents" menu item doesn't start OO.o correctly
"Recent Documents" menu item doesn't start OO.o correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-08 16:16 EDT by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.9.123-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 03:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
recently used xml file (306 bytes, text/plain)
2005-08-08 16:16 EDT, Tom Tromey
no flags Details

  None (edit)
Description Tom Tromey 2005-08-08 16:16:21 EDT
I have version 1.9.120-2.2.0.fc5 installed.
The exact packages are openoffice.org-{math,impress,core,writer}

I wrote a presentation using Impress.
Then I exited openoffice.
My presentation appears in the Gnome "Recent Documents" menu.
However, when I choose this I see an Error dialog saying:

Cannot open recently used document
Details: Couldn't find a suitable application

I'm attaching my ~/.recently-used file

FWIW I have no idea whether this is an OO.o bug, a gnome panel bug, or
something else.  This just seemed like a good place to start.
Comment 1 Tom Tromey 2005-08-08 16:16:21 EDT
Created attachment 117555 [details]
recently used xml file
Comment 2 Caolan McNamara 2005-08-09 03:53:01 EDT
"<Mime-Type>application/octet-stream</Mime-Type>" looks like rubbish to me, 
now I have
"<Mime-Type>application/vnd.oasis.opendocument.presentation</Mime-Type>" for my
.odp that I just created in OOo 1.9.123-1 and gnome-panel-2.11.90-1. Presumably
it was (or is some still existing edgecase I don't see) an OOo mime-type writing
problem.

Tentatively I'll claim it's fixed rawhide.
Comment 3 Tom Tromey 2005-08-12 17:57:40 EDT
I updated to 1.9.123-1.2.0.fc5 and tried again.
I cleared my recently-used files.
I ran OO.o Impress and opened my presentation.
Then I exited.

I still see application/octet-stream as the mime-type.
Comment 4 Caolan McNamara 2005-08-15 04:13:42 EDT
That's very odd, opening .sxi or .odp files is placing correctly typed 
application/vnd.sun.xml.impress and 
application/vnd.oasis.opendocument.presentation mime-types in there for me

Note You need to log in before you can comment on or make changes to this bug.