Bug 1654067 - Remove parent folder path in the tags section on VM details page in SUI
Summary: Remove parent folder path in the tags section on VM details page in SUI
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.z
Assignee: drew uhlmann
QA Contact: Sudhir Mallamprabhakara
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 01:00 UTC by Nandini Chandra
Modified: 2019-05-09 13:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-09 13:37:12 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
screen shot of VM details page (42.70 KB, image/png)
2018-11-28 01:00 UTC, Nandini Chandra
no flags Details

Description Nandini Chandra 2018-11-28 01:00:53 UTC
Created attachment 1509306 [details]
screen shot of VM details page

Description of problem:
-----------------------
See attached screen shot.


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
5.9, 5.10


How reproducible:
----------------
Always


Steps to Reproduce:
-------------------
1.Launch a VM through a service
2.Navigate to the VM details page in SUI.


Actual results:
---------------
Parent folder path in the tags section on VM details page in SUI


Expected results:
-----------------
The parent folder path in the tags section on VM details page in SUI should be removed.


Additional info:
----------------

Comment 3 drew uhlmann 2019-05-09 11:50:18 UTC
Hey Harpreet, I know you said this is API issue but that's actually coming from 
https://github.com/ManageIQ/manageiq/blame/master/app/models/vm_or_template.rb#L1387 which has been in the product for _years_ and it'd be nice to get someone to check to see if this is something I should actually remove since we have specific SUI tests that say that the intended display for that includes the Parent Folder bit: https://github.com/ManageIQ/manageiq-ui-service/blob/ae385823137b78b78b1ea6b8abdee77b0b9b2ac4/tests/mock/blueprint-details/all-tags.json#L4318


Note You need to log in before you can comment on or make changes to this bug.