Bug 1654156 - [admin] listing secrets under all namespaces takes long time for cluster-admin to input env var in dc-creation page
Summary: [admin] listing secrets under all namespaces takes long time for cluster-adm...
Keywords:
Status: CLOSED DUPLICATE of bug 1689980
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Joe Caiani
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 07:14 UTC by XiaochuanWang
Modified: 2019-03-19 12:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-19 12:39:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
timing of HTTP Request to list all secrets. (137.60 KB, image/png)
2018-11-28 07:14 UTC, XiaochuanWang
no flags Details

Description XiaochuanWang 2018-11-28 07:14:18 UTC
Created attachment 1509391 [details]
timing of HTTP Request to list all secrets.

Description of problem:
As per design, there is no secret/configmap selection when creating dc (from image), see https://github.com/openshift/console/pull/676#issuecomment-432340830
When cluster-admin user create dc -> from image, the "Environment Variables" tables get more than 10 seconds to show up

Version-Release number of selected component (if applicable):
openshift/oc v4.0.0-0.74.0
registry.reg-aws.openshift.com:443/openshift/ose-console                   v4.0                32d268ebfeeb 

How reproducible:
Always

Steps to Reproduce:
1. cluster-admin user login and choose a project.
2. Go to Deployment Configs page, click create -> From Form, input "php" and search.

Actual results:
2. "Environment Variables" tables get more than 10 seconds to show up (please refer to the screenshot)

Expected results:
2. Since we don't support add env from secret/configmap, it's better not to request secrets/configmap which takes long time to show up

Additional info:
https://github.com/openshift/console/pull/676#issuecomment-432340830

Comment 2 Samuel Padgett 2019-03-19 12:39:49 UTC

*** This bug has been marked as a duplicate of bug 1689980 ***


Note You need to log in before you can comment on or make changes to this bug.