Bug 1654242 - Missing documentation for fast forward upgrades about changes of roles
Summary: Missing documentation for fast forward upgrades about changes of roles
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Roger Heslop
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
: 1651719 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-28 10:20 UTC by Yolanda Robla
Modified: 2019-04-30 18:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
* In case you want to enable DPDK in a compute, you will need to add the following services and extra parameters in your role definition: RoleParametersDefault: VhostuserSocketGroup: "hugetlbfs" TunedProfileName: "cpu-partitioning" ServicesDefault: - OS::TripleO::Services::ComputeNeutronOvsDpdk And remove: ServicesDefault: - OS::TripleO::Services::ComputeNeutronOvsAgent - OS::TripleO::Services::NeutronLinuxbridgeAgent - OS::TripleO::Services::NeutronVppAgent - OS::TripleO::Services::Tuned In case you want to enable SRIOV in a compute, you will need to add the following services and extra parameters in your role definition: RoleParametersDefault: TunedProfileName: "cpu-partitioning" ServicesDefault: - OS::TripleO::Services::NeutronSriovAgent - OS::TripleO::Services::NeutronSriovHostConfig And remove: ServicesDefault: - OS::TripleO::Services::NeutronLinuxbridgeAgent - OS::TripleO::Services::Tuned
Clone Of:
Environment:
Last Closed: 2019-04-30 18:57:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yolanda Robla 2018-11-28 10:20:12 UTC
Description of problem:

When performing a fast forward upgrade, there is no information about the changes of services for NFV cases. In https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/13/html/fast_forward_upgrades/assembly-preparing_for_overcloud_upgrade#new-composable-services, it mentions about composable services, but it doesn't make any mention of the services needed for NFV.

So 2 cases are missing: SRIOV and DPDK. There should be an specific section there, for NFV, with that content:

* In case you want to enable DPDK in a compute, you will need to add the following services and extra parameters in your role definition:

  RoleParametersDefault:
    VhostuserSocketGroup: "hugetlbfs"
    TunedProfileName: "cpu-partitioning"

  ServicesDefault:
    - OS::TripleO::Services::ComputeNeutronOvsDpdk

And remove:

  ServicesDefault:
    - OS::TripleO::Services::ComputeNeutronOvsAgent
    - OS::TripleO::Services::NeutronLinuxbridgeAgent
    - OS::TripleO::Services::NeutronVppAgent
    - OS::TripleO::Services::Tuned


In case you want to enable SRIOV in a compute, you will need to add the following services and extra parameters in your role definition:

  RoleParametersDefault:
    TunedProfileName: "cpu-partitioning"
  ServicesDefault:
    - OS::TripleO::Services::NeutronSriovAgent
    - OS::TripleO::Services::NeutronSriovHostConfig

And remove:

  ServicesDefault:
    - OS::TripleO::Services::NeutronLinuxbridgeAgent
    - OS::TripleO::Services::Tuned

Comment 1 Priscila 2018-12-13 16:20:45 UTC
*** Bug 1651719 has been marked as a duplicate of this bug. ***

Comment 9 Roger Heslop 2019-04-23 16:05:03 UTC
Saravanan - Checkout out the document we were looking at the other week, I've marked some text in red to see if this adequately satisfies: https://docs.google.com/document/d/12QzNe7AOeQK1WSlsiSK5Gu4k_MilVbhMLPe7QKiiCLs/edit

Comment 10 Saravanan KR 2019-04-24 13:17:07 UTC
(In reply to Roger Heslop from comment #9)
> Saravanan - Checkout out the document we were looking at the other week,
> I've marked some text in red to see if this adequately satisfies:
> https://docs.google.com/document/d/
> 12QzNe7AOeQK1WSlsiSK5Gu4k_MilVbhMLPe7QKiiCLs/edit

Document flow is perfect. Added a comment though, if solved, its good to go.


Note You need to log in before you can comment on or make changes to this bug.