Bug 165434 - debugedit should canoncalize names in directory table (PATCH)
debugedit should canoncalize names in directory table (PATCH)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 06:16 EDT by Roland McGrath
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-25 11:21:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch fixing debugedit to canonicalize directory names in directory tables (2.10 KB, patch)
2005-08-09 06:16 EDT, Roland McGrath
no flags Details | Diff

  None (edit)
Description Roland McGrath 2005-08-09 06:16:29 EDT
Description of problem:

You can wind up with debuginfo rpms where the .debug data uses file names that
don't work to find the source files in the rpm.  For example, the directory
table in the DWARF info might say /usr/src/debug/foo-1.2.3/build/../src
when in fact /usr/src/debug/foo-1.2.3/build does not exist at all though
/usr/src/debug/foo-1.2.3/src does exist.

elfutils-0.112-1 (in dist-fc5) is an example of a package built with this
problem (elfutils-debuginfo-0.112-1), though later elfutils builds already in
dist-fc5 don't demonstrate this issue.

The cpio that find-debuginfo.sh does to copy files into /usr/src/debug
effectively canonicalizes the directory names, since a directory foo
is not created if it only appears in foo/../bar file names.  So, debugedit needs
to canonicalize the directory names in the DWARF information as well, to make
sure that they can be found in /usr/src/debug.

Version-Release number of selected component (if applicable):
4.4.2-3

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Roland McGrath 2005-08-09 06:16:29 EDT
Created attachment 117568 [details]
patch fixing debugedit to canonicalize directory names in directory tables
Comment 2 Jeff Johnson 2005-08-25 11:20:27 EDT
Added to rpm-4_4 cvs, should be in rpm-4.4.3-0.4 when built.

Note You need to log in before you can comment on or make changes to this bug.