Bug 165462 - hkp protocol is broken
hkp protocol is broken
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnupg (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 12:22 EDT by Robin Green
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.4.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 14:17:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-08-09 12:22:00 EDT
Description of problem:
When I try to verify a signature with an unknown key, gpg fails to auto-fetch
the key from hkp://subkeys.pgp.net because the hkp protocol handler has been
installed in an unexpected place.

Version-Release number of selected component (if applicable):
1.4.2-2

How reproducible:
Always

Steps to Reproduce:
1. Add/uncomment the following lines to gpg.conf:
keyserver hkp://subkeys.pgp.net
keyserver-options auto-key-retrieve

2. Attempt to verify a signature whose key you do not have
  
Actual results:
gpg: unable to execute program `/usr/lib/gnupg/gpgkeys_hkp': No such file or
directory
gpg: Signature made Tue 09 Aug 2005 15:43:13 BST using DSA key ID 81CFE75D
gpg: requesting key 81CFE75D from hkp server subkeys.pgp.net
gpg: no handler for keyserver scheme `hkp'
gpg: Can't check signature: public key not found

Expected results:
The first line should not appear, and the hkp handler should therefore be loaded
and succeed in fetching the key.

Additional info:
This started happening after a recent yum upgrade.
The file searched for is in /usr/lib/gnupg/gnupg/gpgkeys_hkp instead of
/usr/lib/gnupg/gpgkeys_hkp
Comment 1 Nalin Dahyabhai 2005-08-09 14:17:45 EDT
Oops, looks like a workaround for libexec/lib confusion wasn't needed any more
as of 1.4.2.

Note You need to log in before you can comment on or make changes to this bug.