Bug 1654629 - Operation Execute CLI commands sometimes fails on EAP 7
Summary: Operation Execute CLI commands sometimes fails on EAP 7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7
Version: JON 3.3.11
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: CR02
: One-off release
Assignee: Josejulio Martínez
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks: 1533642 1543522
TreeView+ depends on / blocked
 
Reported: 2018-11-29 09:49 UTC by Filip Brychta
Modified: 2019-01-31 15:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 15:54:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Filip Brychta 2018-11-29 09:49:39 UTC
Description of problem:
Operation Execute CLI commands sometimes fails on EAP 7.2 with:
Unable to connect due to unrecognised server certificate. Server's certificate needs to be manually accepted by user.


Version-Release number of selected component (if applicable):
JON 3.3.11  + EAP plugin pack08.CR01

How reproducible:
Sometimes

Steps to Reproduce:
1. start EAP 7.2 in domain mode (jboss-eap-7.2/bin/domain.sh)
2. import it from Discovery queue
3. Run Operation 'Install a management user'
4. Run Operation 'Execute CLI commands' with e.g. :whoami

Actual results:
Operation fails with Unable to connect due to unrecognised server certificate. Server's certificate needs to be manually accepted by user.

Expected results:
Operation is executed successfully.

Additional info:
Following process is visible on the host when the operation is in progress:
hudson    4730  3945 16 04:17 pts/0    00:00:01 /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-1.el7_6.x86_64/jre/bin/java -Djboss.modules.system.pkgs=com.sun.java.swing -Dcom.ibm.jsse2.overrideDefaultTLS=true -Dlogging.configuration=file:/home/hudson/jboss-eap-7.2/bin/jboss-cli-logging.properties -jar /home/hudson/jboss-eap-7.2/jboss-modules.jar -mp /home/hudson/jboss-eap-7.2/modules org.jboss.as.cli --connect :whoami --user=rhqadmin --password=rhqadmin --controller=http-remoting://127.0.0.1:9990 -Drhq.as7.plugin.exec-id=e4a7d864-aa32-4464-b9e9-408a20d97340

When running the jboss-cli manually with the same arguments (--connect :whoami --user=rhqadmin --password=rhqadmin --controller=http-remoting://127.0.0.1:9990 -Drhq.as7.plugin.exec-id=e4a7d864-aa32-4464-b9e9-408a20d97340) it's working as expected.

Probably it's caused by hardcoded timeout https://github.com/rhq-project/rhq/blob/75211fae4e10f846023158091023b3e87677ea4a/modules/plugins/wfly-10/src/main/java/org/rhq/modules/plugins/wildfly10/ServerControl.java#L253

Maybe it takes longer now on EAP 7.2? Maybe it's just slow QE environment but I have never seen this on EAP 7.1.


Note You need to log in before you can comment on or make changes to this bug.