Bug 165463 - kernel oops in dentry_open
kernel oops in dentry_open
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 12:27 EDT by Mark Tinberg
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 20:36:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Tinberg 2005-08-09 12:27:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050715 Firefox/1.0.6 SUSE/1.0.6-4.1

Description of problem:
Notices this kernel oops in the logs.  This was not associated with any downtime or failure that I have been able to determine.  The system is still up and running normally.  Thought I'd just file this for posterity.

Unable to handle kernel paging request at virtual address f8a92080
 printing eip:
c0154af2
*pde = 00000000
Oops: 0000 [#1]
SMP 
Modules linked in: dcdesm(U) dcdbas(U) md5 ipv6 i2c_dev i2c_core sunrpc button b
attery ac ohci_hcd e100 mii tg3 floppy dm_snapshot dm_zero dm_mirror ext3 jbd dm
_mod aacraid sd_mod scsi_mod
CPU:    0
EIP:    0060:[<c0154af2>]    Tainted: P      VLI
EFLAGS: 00010282   (2.6.9-5.ELsmp) 
EIP is at dentry_open+0x78/0x1a5
eax: f8a92080   ebx: c41cfe20   ecx: dead4ead   edx: c499150c
esi: f1d42e50   edi: c19e59e0   ebp: ffffffe9   esp: de7b6f40
ds: 007b   es: 007b   ss: 0068
Process wc (pid: 15882, threadinfo=de7b6000 task=dcdc79d0)
Stack: c499150c de7b6f58 00008000 e41e4000 de7b6000 c0154a74 c499150c c19e59e0 
       00000001 00000000 00000246 00000101 00000001 00000000 de7b6f80 c02c48be 
       e41e4000 c01b78a6 00000000 00000003 bff5f6a2 f7b90040 ffffffe8 00008001 
Call Trace:
 [<c0154a74>] filp_open+0x36/0x3c
 [<c02c48be>] __cond_resched+0x14/0x39
 [<c01b78a6>] direct_strncpy_from_user+0x3e/0x5d
 [<c0154d73>] sys_open+0x31/0x7d
 [<c02c62a3>] syscall_call+0x7/0xb
Code: ac 00 00 00 89 83 98 00 00 00 8b 04 24 89 7b 0c c7 43 24 00 00 00 00 89 43
 08 c7 43 28 00 00 00 00 8b 86 a0 00 00 00 85 c0 74 29 <8b> 10 85 d2 74 1b b8 00
 f0 ff ff 21 e0 83 3a 02 8b 40 10 74 14 


Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-5.EL

How reproducible:
Didn't try


Additional info:
Comment 1 Dave Jones 2005-08-26 20:36:11 EDT
Those binary modules make this very difficult to root cause.
There's not a lot we can do here.

Dell may be able to do more with this than we can.

Note You need to log in before you can comment on or make changes to this bug.