Bug 165478 - Please add the USB-patches to openobex(-apps)
Please add the USB-patches to openobex(-apps)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openobex (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 14:26 EDT by Panu Matilainen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-23 06:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Panu Matilainen 2005-08-09 14:26:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
http://www.sensi.org/~ak/openobex-usb/ has two patches which enable using USB cable for obex-transfers which is an order of magnitude faster than for example Bluetooth. Please include these patches is future versions of openobex and openobex-apps (although the apps patch only adds usb support to obex_test command it's still useful for, well, testing purposes)

I've tested the patches on RHEL 4 + openobex rebuilt from FC4 and they do actually work. :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Apply the patches in the url above
2. Watch file transfers fly :)
  

Additional info:
Comment 1 Harald Hoyer 2005-08-23 06:05:18 EDT
The author states:
>> The patches in the current form are not suitable for including into OpenOBEX,
because they change the library API in a sub-optimal way. I'm planning to write
a proper version soon. <<

If you want these patches, just try to get them upstream please, so all
distributions can benefit from it.

Thx
Comment 2 Alex Kanavin 2006-02-07 12:22:17 EST
There is now a new upstream release of openobex (version 1.1) with USB support
included so perhaps it's time to update :)

Note You need to log in before you can comment on or make changes to this bug.