This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 165499 - autofs init script incorrectly handles auto.master options
autofs init script incorrectly handles auto.master options
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: autofs (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 17:17 EDT by Brian Long
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-20 12:43:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Long 2005-08-09 17:17:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050607 VRP Inc/1.7.8-5

Description of problem:
The automount init script appears to handle automount options specified per map in /etc/auto.master incorrectly.  For example, I have the following in /etc/auto.master:
/misc   /etc/auto.misc          --timeout 60
/auto   /etc/auto.indirect      rsize=32768,wsize=32768,tcp
/users  auto_home               rw,hard,intr,rsize=32768,wsize=32768,tcp

This means an automount process for /misc should be started with --timeout 60, but the other automount processes for /auto and /users should be started with no options.

Version-Release number of selected component (if applicable):
autofs-4.1.3-130

How reproducible:
Always

Steps to Reproduce:
1. Specify auto.master as specified in the description.
2. Run service autofs start

  

Actual Results:  > ps -ef | grep autom
root      3339     1  0 09:36 ?        00:00:00 /usr/sbin/automount --timeout=60 /misc file /etc/auto.misc
root      3364     1  0 09:36 ?        00:00:00 /usr/sbin/automount --timeout=60 /auto file /etc/auto.indirect rsize=32768,wsize=32768,tcp
root      3417     1  0 09:36 ?        00:00:21 /usr/sbin/automount --timeout=60 /users yp auto.home rw,hard,intr,rsize=32768,wsize=32768,tcp


Expected Results:  > ps -ef | grep autom
root      3339     1  0 09:36 ?        00:00:00 /usr/sbin/automount --timeout=60 /misc file /etc/auto.misc
root      3364     1  0 09:36 ?        00:00:00 /usr/sbin/automount /auto file /etc/auto.indirect rsize=32768,wsize=32768,tcp
root      3417     1  0 09:36 ?        00:00:21 /usr/sbin/automount /users yp auto.home rw,hard,intr,rsize=32768,wsize=32768,tcp


Additional info:
Comment 1 Brian Long 2005-08-09 17:53:02 EDT
Even worse, if I change auto.master to the following:
/misc   /etc/auto.misc          --timeout 60
/auto   /etc/auto.indirect      --timeout 300 rsize=32768,wsize=32768,tcp
/users  auto_home           --timeout 300 rw,hard,intr,rsize=32768,wsize=32768,tcp

The automount processes are still started with --timeout 60:
> ps -ef | grep automou
root      3365     1  0 17:22 ?        00:00:00 /usr/sbin/automount --timeout=60
/misc file /etc/auto.misc
root      3367     1  0 17:22 ?        00:00:00 /usr/sbin/automount --timeout=60
/auto file /etc/auto.indirect rsize=32768,wsize=32768,tcp
root      3401     1  0 17:22 ?        00:00:02 /usr/sbin/automount --timeout=60
/users yp auto.home rw,hard,intr,rsize=32768,wsize=32768,tcp

This means I have no workaround to my current problem.  I want misc to timeout
in 1 minute and /auto and /users to timeout in the default 5 minutes.
Comment 3 Jeffrey Moyer 2005-08-12 08:59:03 EDT
DAEMONOPTIONS has a default value of --timeout=60.  If you disable that, then
per-map timeout options will work.  You could make a case for preferring options
in auto.master over the global setting in /etc/sysconfig/autofs.

Is that what is requested, here?  If not, please let me know if you think it is
okay to close this bug.

Thanks.
Comment 4 Jeffrey Moyer 2005-09-19 17:39:39 EDT
Still waiting for an update to this bug.  Please respond to comment #3.
Comment 5 Brian Long 2005-09-20 10:42:27 EDT
The problem is that we've been using the same auto.master from RH 7.1 and 7.3. 
In that file, we had "--timeout 60" for /misc and it worked fine (see comment #1
and #2).  It turns out that the init script in RHEL 3 requires "--timeout=60". 
The = sign is new in RHEL 3, it appears.  Somehow this slight change (and the
global DAEMONOPTIONS) slipped through our testing, so --timeout=60 is set for
all automount processes.

I don't know why "--timeout 60" is no longer supported by the init script, but
this is what caused the primary bug I thought I was filing  :)

I am currently verifying our existing RH 7.3 hosts like the new "--timeout=60"
auto.master option (since we push a single autofs-config RPM to all clients). 
As long as my older RH 7.3 hosts can handle the =, we can close this bug.
Comment 6 Jeffrey Moyer 2005-09-20 10:50:04 EDT
Thanks very much for the clarification.  Definitely let me know whether or not
this works.
Comment 7 Brad Hinson 2005-09-20 12:43:28 EDT
Issue Tracker has been closed.

Note You need to log in before you can comment on or make changes to this bug.