Bug 165500 - PXE boot config file for PXE install clients unusable if kickstart file has not been specified
PXE boot config file for PXE install clients unusable if kickstart file has n...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-netboot (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 156322
  Show dependency treegraph
 
Reported: 2005-08-09 17:27 EDT by Jason Vas Dias
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2005-484
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 09:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Vas Dias 2005-08-09 17:27:22 EDT
+++ This bug was initially created as a clone of Bug #164776 +++

Description of problem:
If you configure a client for 'Network OS install' and leave the 'Kickstart
File' field empty, the installation of the client will fail because it cannot
find a kickstart file named "". 

Version-Release number of selected component (if applicable):
system-config-netboot-0.1.20-1_EL4

How reproducible:
Always

Steps to Reproduce:
1. start redhat-config-netboot
2. configure a Network Installation profile
3. configure a client with this profile and leave the 'kickstart file' field empty.
4. boot the client
  
Actual results:
The installation will fail at the point where it tries to download the kickstart
file, complaining it cannot find it.

Expected results:
The install should continue interactively.

Additional info:
Doing kickstart-less network installs may sound unusual, but it is very
convenient for systems where you cannot boot from CD/DVD.
In redhat-config-netboot the problem can be solved easily by checking whether a
kickstart file has been specified and ommitting the 'ks=' parameter if it hasn't.
But maybe the proper solution would be if the installer compononent (anaconda?)
would interpret an empty ks parameter as equivalent to no kickstart file at all.
Comment 1 Jason Vas Dias 2005-08-09 17:35:54 EDT
This is fixed with system-config-netboot-0.1.24-1_EL4 .

Comment 7 Red Hat Bugzilla 2005-10-05 09:49:06 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-484.html

Note You need to log in before you can comment on or make changes to this bug.