Bug 165502 - incorrect comment asterisk in XAnyEvent.3x man page
incorrect comment asterisk in XAnyEvent.3x man page
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-08-09 17:51 EDT by Ben Liblit
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-30 15:30:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 4312 None None None Never

  None (edit)
Description Ben Liblit 2005-08-09 17:51:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
The XAnyEvent.3x manual page includes a few C syntax comments explaining fields of the XAnyEvent structure.  When rendered in a Unicode (UTF-8) locale, the asterisk in the opening "/*" part is the wrong character.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run this command: env LANG=en_US.UTF-8 man XAnyEvent
2. Examine the C comments next to the serial, send_event, and display fields of the XAnyEvent struct.

Actual Results:  The comments begin with "/∗".  That second character looks like an asterisk, but it is actually Unicode character U+2217 ASTERISK OPERATOR.

Expected Results:  C comments should begin with "/*", where the second character is an ASCII asterisk, also known as Unicode character U+002A ASTERISK.

Additional info:

Be sure you are using a UTF-8 locale when viewing the man page.  If LANG=C, you won't see the problem.

When fixing this, give a quick grep through the other X man pages.  I expect there are other examples of the same problem.
Comment 1 Mike A. Harris 2005-08-30 07:16:27 EDT
This seems to be X.Org specific, and not Red Hat or Fedora specific.

Please report issues of this nature to X.Org developers by filing a
bug report in the X.Org bugzilla located at http://bugs.freedesktop.org
in the "xorg" component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL for tracking.
Comment 2 Ben Liblit 2005-08-30 15:30:53 EDT
Reported upstream to FreeDesktop.org as requested.  I've added the appropriate
reference to the "External Bugzilla References" section here.  Marking as
resolved UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.