Bug 1655057 - ISO is doubled in the VM Attach CD option
Summary: ISO is doubled in the VM Attach CD option
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.3.1
: 4.3.0
Assignee: Andrej Krejcir
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 12:45 UTC by Jaroslav Spanko
Modified: 2019-01-30 13:11 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-30 13:10:43 UTC
oVirt Team: Virt
Target Upstream Version:


Attachments (Terms of Use)
doubled iso (26.34 KB, image/png)
2018-11-30 12:47 UTC, Jaroslav Spanko
no flags Details
iso domain list (25.69 KB, image/png)
2018-12-01 16:07 UTC, Jaroslav Spanko
no flags Details
only one iso on domain also doubled (20.53 KB, image/png)
2018-12-01 16:07 UTC, Jaroslav Spanko
no flags Details
ISO_list_012019.png (192.93 KB, image/png)
2019-01-30 13:11 UTC, Nisim Simsolo
no flags Details

Description Jaroslav Spanko 2018-11-30 12:45:13 UTC
Description of problem:
In the VM->Edit->Boot Options->Attach CD the uploaded ISO is doubled.
This problem is only in this option, ISO domain-> Images looks OK

Version-Release number of selected component (if applicable):
rhvm-4.3.0-0.5.alpha1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Upload iso to the ISO domain
2. Attach iso via Edit 
3. In the Attach CD ISO is doubled

Actual results:
Uploaded ISO is doubled 

Expected results:
Correct ISO list output

Additional info:
vdsm call
-----------------------------
2018-11-30 13:37:08,017+0100 INFO  (jsonrpc/1) [vdsm.api] FINISH getFileStats return={'fileStats': {u'7601.17514.101119-1850_x64fre_server_eval_en-us-GRMSXEVAL_EN_DVD.iso': {'status': 0, 'ctime': '1543581083.0', 'size': '3166840832'}, u'RHV-toolsSetup_4.2_5.iso': {'status': 0, 'ctime': '1543511282.0', 'size': '759447552'}}} from=::ffff:10.37.193.13,47066, flow_id=63128a90-bda5-45d9-8cca-176b3eb87d3b, task_id=64b65801-7bbc-4dba-a0e1-a1b4a4247c3c (api:54)
-----------------------------
engine call
-----------------------------
2018-11-30 13:37:08,019+01 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.GetFileStatsVDSCommand] (default task-9) [63128a90-bda5-45d9-8cca-176b3eb87d3b] FINISH, GetFileStatsVDSCommand, return: {7601.17514.101119-1850_x64fre_server_eval_en-us-GRMSXEVAL_EN_DVD.iso={status=0, ctime=1543581083.0, size=3166840832}, RHV-toolsSetup_4.2_5.iso={status=0, ctime=1543511282.0, size=759447552}}, log id: 385aa2cc
2018-11-30 13:37:08,383+01 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (default task-9) [63128a90-bda5-45d9-8cca-176b3eb87d3b] EVENT_ID: REFRESH_REPOSITORY_IMAGE_LIST_SUCCEEDED(998), Refresh image list succeeded for domain(s): ISO (All file type)
-----------------------------

Also attaching screenshots

Comment 1 Jaroslav Spanko 2018-11-30 12:47:54 UTC
Created attachment 1510128 [details]
doubled iso

Comment 2 Ryan Barry 2018-12-01 14:06:19 UTC
You're sure it was only uploaded once?

Comment 3 Jaroslav Spanko 2018-12-01 16:06:37 UTC
Hi
Yes, it's not related to one iso, if i leave on iso domain different iso the same - doubled.
Attaching screentshots

Comment 4 Jaroslav Spanko 2018-12-01 16:07:01 UTC
Created attachment 1510429 [details]
iso domain list

Comment 5 Jaroslav Spanko 2018-12-01 16:07:26 UTC
Created attachment 1510430 [details]
only one iso on domain also doubled

Comment 6 Jaroslav Spanko 2018-12-02 15:44:29 UTC
Before i forget, isos are still doubled, i tried
------------------
engine restart
iso domain refresh
3 different browsers
------------------
Thanks !

Comment 9 Andrej Krejcir 2018-12-03 13:42:43 UTC
No, that change only sorts a list. It cannot duplicate its items.

Comment 10 Ryan Barry 2019-01-21 14:53:55 UTC
Re-targeting to 4.3.1 since it is missing a patch, an acked blocker flag, or both

Comment 12 Ryan Barry 2019-01-30 12:59:31 UTC
Nisim, if this isn't reproducible, please close

Comment 13 Nisim Simsolo 2019-01-30 13:10:43 UTC
Closing as "WORKSFORME":
ovirt-engine-4.3.0-0.8.master.20190122121624.git9a8a519.el7
vdsm-4.30.8-9.gitf28e377.el7.x86_64
libvirt-4.5.0-10.el7_6.4.x86_64
qemu-kvm-ev-2.12.0-18.el7_6.3.1.x86_64

Verification scenario:
1. Edit VM -> boot options -> check 'attach CD' checkbox
2. Verify ISO list is not doubled, also, scroll the list if you have a lot of ISOs in order to verify that the samo ISO is not listed again.

Please see attached screenshot: ISO_list_012019.png

Comment 14 Nisim Simsolo 2019-01-30 13:11:42 UTC
Created attachment 1525031 [details]
ISO_list_012019.png


Note You need to log in before you can comment on or make changes to this bug.