Bug 165512 - Unable to add a printer
Unable to add a printer
Status: CLOSED DUPLICATE of bug 165328
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 19:13 EDT by Paul F. Johnson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-10 04:39:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul F. Johnson 2005-08-09 19:13:52 EDT
Description of problem:
s-c-printer dies when attempting to add a printer

Version-Release number of selected component (if applicable):
0.6.139-1

How reproducible:
Always

Steps to Reproduce:
1. Open a terminal window, start system-config-printer
2. Click to add a new printer
3.
  
Actual results:
The software hands with the following throwback

No match for USB device:
  mfr "Samsung"
  model "ML-2250"
  desc ""
  cmdset "PCL5E,PCL6"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.
No match for USB device:
  mfr "HEWLETT-PACKARD"
  model "DESKJET 980C"
  desc "Hewlett-Packard DeskJet 980C"
  cmdset "MLC,PCL,PML"
Please report this message in Bugzilla:
  https://bugzilla.redhat.com/bugzilla
Choose 'foomatic' as the component.
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 581, in new_button_clicked
    self.addQueue.addQueueDruid ()
  File "/usr/share/printconf/util/addQueue.py", line 277, in addQueueDruid
    window = self.window.window)
  File "/usr/share/printconf/util/queueTree.py", line 910, in populate_model_store
    models = self.conf.foomatic.make_model_dict_dict[mfr].keys ()
KeyError: 'Generic'
Traceback (most recent call last):
  File "/usr/sbin/system-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 1242, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 280, in __init__
    gtk.main ()
KeyboardInterrupt

Expected results:
I should be able to add a printer

Additional info:
Comment 1 Tim Waugh 2005-08-10 04:39:58 EDT
Same root cause as bug #165328, fixed in 0.6.140-1.

*** This bug has been marked as a duplicate of 165328 ***
Comment 2 Lisa Lu 2006-02-17 12:33:42 EST
need more info

Note You need to log in before you can comment on or make changes to this bug.