Bug 165522 - Recommended spec file changes for RHEL4 support
Recommended spec file changes for RHEL4 support
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nexuiz (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 23:07 EDT by Randy Zagar
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: nexuiz-1.1-2.fc4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-16 04:58:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Zagar 2005-08-09 23:07:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The current FC4 spec file does not work on RHEL4 systems.  The problem is that the command

    convert nexuiz.ico nexuiz.png

produces files with names like 'nexuiz-[0-9].png' on FC4 systems, but produces files with names like 'nexuiz.png.[0-9]' on RHEL4 sytems.

This can be fixed by changing one line in the %install section from

    for file in nexuiz*.png; do

to

    for file in nexuiz*.png*; do
    



Version-Release number of selected component (if applicable):
nexuiz-1.1-1

How reproducible:
Always

Steps to Reproduce:
1. Log onto RHEL4 system
2. rpmbuild --rebuild \
       http://mirrors.kernel.org/fedora/extras/4/SRPMS/nexuiz-1.1-1.fc4.src.rpm

  

Additional info:
Comment 1 Adrian Reber 2005-08-16 04:58:30 EDT
Fix included in current version (nexuiz-1.1-2.fc4).

Note You need to log in before you can comment on or make changes to this bug.