This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 165523 - DTMF tones not correctly generated
DTMF tones not correctly generated
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kphone (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-09 23:10 EDT by Stefan Becker
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 13:16:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Becker 2005-08-09 23:10:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The DTMF tones generated by kphone are not correct and therefore not recognized by other systems, e.g. voice mailboxes.

Version-Release number of selected component (if applicable):
kphone-4.x, kernel-2.6 (?)

How reproducible:
Always

Steps to Reproduce:
1. Dial an automated DTMF-controlled system, e.g. voice mailbox
2. Send DTMF tones
3.
  

Actual Results:  DTMF tones are not recognized, ie. the menu system of a voice mailbox doesn't work, making it unusable.

Expected Results:  You should be able to control audio menus with DTMF tones generated by kphone.

Additional info:

The DTMF tones generated by kphone are not "clean" enough. The tones are interrupted by short pauses e.g. "tttttttt-tttttttt-tttt....". It looks like the DTMF generator doesn't feed the audio output driver with data fast enough which causes buffer underruns, ie. short silences.

I remember that I tested DTMF with kphone-4.0.x on an older FC release (2?) and they worked OK. It could be that they worked OK on kernel 2.4 with OSS, but stopped working on kernel 2.6 with ALSA (also through OSS emulator before kphone-4.1.x).
Comment 1 Dennis Gilmore 2005-08-10 07:55:21 EDT
quick question.  what are you connecting to via kphone?  a voip provider?  
asterisk?  something else? 
Comment 2 Stefan Becker 2005-08-10 10:59:24 EDT
I'm connecting to a VoIP provider (sipgate.de).
Comment 3 Dennis Gilmore 2005-08-10 12:01:52 EDT
Do they offer anyway to configure  how  you send them dtmf signals.  dtmf is
working for me with my local asterisk boxes.  i did have to tell asterisk  the
the dtmfmode is inband.  rfc2833 mode didnt work for me  and i didnt try info.
Comment 4 Stefan Becker 2005-08-10 12:41:53 EDT
They don't offer any DTMF options in their SIP configuration.

I remember that linphone has an option to send DTMF via RFC2833. So I think this
can be controlled by the client. What does kphone do? Does it look at some
capability reported by the registation server or the proxy?
Comment 5 Dennis Gilmore 2005-08-10 14:55:14 EDT
im not sure exactly what kphone does with regards to dtmf sending.  my guess is
that it just sends it inline.  i will have a look into it more.  Im about to
file a few usability bugs upstream.  this should be a user configurable option.
 i also found out you can be in a call and close the call window  call remains
active  but you have no way to end the call except to quit kphone.

i also have my microphone in in a logitech quickcam, kphone select mic jack on
sound card there is no user configurable way to select input devices.  
Comment 6 Stefan Becker 2005-08-10 15:45:38 EDT
I'm using ALSA as audio driver. Either with a USB headset or a Bluetooth headset
via bluetooth-alsa driver.
Comment 7 Stefan Becker 2006-10-01 16:16:37 EDT
twinkle has been added to FC6 Extras development. IMHO this bug can be closed
now as we should drop kphone from Extras.
Comment 8 Dennis Gilmore 2006-10-06 13:16:39 EDT
Works for me.  kphone will stay in extras  there is no reason to drop it.

Comment 9 Jima 2006-10-06 13:23:05 EDT
As the reviewer of twinkle, I'm not sure what you're talking about.  I put in my
effort to give users more choice in software, not replace existing software. 
I'd reject any motion to remove kphone based on that reasoning out of hand.

Note You need to log in before you can comment on or make changes to this bug.