Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1655295 - cockpit - wrong dependencies
Summary: cockpit - wrong dependencies
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cockpit
Version: 28
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Martin Pitt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-02 13:34 UTC by Ben Herrick
Modified: 2018-12-03 09:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-03 09:22:19 UTC
Type: Bug


Attachments (Terms of Use)
Example dnf remove command for cockpit on Fedora 28. (3.68 KB, text/plain)
2018-12-02 13:36 UTC, Ben Herrick
no flags Details

Description Ben Herrick 2018-12-02 13:34:06 UTC
Description of problem:
The f28 cockpit packages cannot be removed without removing system components.

Version-Release number of selected component (if applicable):
cockpit-system-182-1.fc28.noarch

How reproducible:
Always

Steps to Reproduce:
1. dnf remove cockpit-*
2. Look on on horror as dnf tries to remove system components.
3. Decline to remove packages due to unneeded dependencies on cockpit.

Actual results:
cockpit cannot be removed.

Expected results:
cockpit is an optional interface for managing a Fedora system, packages should be easily removed without the need to remove any other packages.

Additional info:

Comment 1 Ben Herrick 2018-12-02 13:36:09 UTC
Created attachment 1510611 [details]
Example dnf remove command for cockpit on Fedora 28.

Comment 2 Stef Walter 2018-12-03 09:22:19 UTC
None of the packages in question are required system components. Your Fedora system will function without the packages there. 

Fedora is trying to remove unneeded and unused dependencies that were brought in to make Cockpit work. You can add any of them back should you need them specifically.


Note You need to log in before you can comment on or make changes to this bug.