Bug 165531 - nscd segfaults on --invalidate=hosts
Summary: nscd segfaults on --invalidate=hosts
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-10 09:11 UTC by Marek Greško
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.3.5-10.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-12 13:00:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marek Greško 2005-08-10 09:11:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; sk-SK; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
nscd segfaults on --invalidate=hosts and also in other situations which I am not aware of.

Version-Release number of selected component (if applicable):
nscd-2.3.5-10

How reproducible:
Sometimes

Steps to Reproduce:
1. Run nscd.
2. Execute nscd --invalidate=hosts
3. Firstly run nscd crashes
  

Actual Results:  nscd daemon crashes on --invalidate=hosts.

Expected Results:  nscd invalidates hosts table and continues running

Additional info:

nscd also crashes in another situations but I am not able to reproduce them.

Comment 1 Jakub Jelinek 2005-08-10 14:46:35 UTC
nscd-2.3.5-10 has been miscompiled, so it (sometimes) creates corrupted
persistent database files.  Please try nscd-2.3.5-10.2 from FC4 testing updates
(and make sure to rm -f /var/db/nscd/* after the upgrade).

Comment 2 Marek Greško 2005-08-11 12:04:55 UTC
nscd-2.3.5-10.2 seems to solve the problem.



Note You need to log in before you can comment on or make changes to this bug.