Bug 165559 - telnet <host> command fail if client hostname is > 35 chars
telnet <host> command fail if client hostname is > 35 chars
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: telnet (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 10:13 EDT by Jens R. Victorin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: telnet-0.17-35.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 11:04:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens R. Victorin 2005-08-10 10:13:34 EDT
Description of problem:
It is not possible to connect to a telnetserver on a host (Solaris 6 in my case)
if the name of the client returned by "hostname" is > 35 chars in length

Version-Release number of selected component (if applicable):
telnet-0.17-28.FC2.1

How reproducible:
Always


Steps to Reproduce:
1.set hostname to a string >35 chars in length ( e.g
1234567890123456789012.12.12.12345678.12)
2.try to connect using "telnet <host>"

  
Actual results:
A locked up terminal showing

Trying <ip>...
Connected to <server>
Escape character is '^]'.



Expected results:
A working session
(i.e 
SunOS 5.6

login:)


Additional info:
Putty works...
Comment 1 Jens R. Victorin 2005-08-10 10:21:24 EDT
Well! Obviously I did not count the dots in the name. The limit seems to be 39
chars. 
Comment 2 Karsten Hopp 2006-05-10 11:04:49 EDT
this works for me in FC-5, I've set up a system with hostname
'thisisaverylonghostnamelongerthanfortycharacters' and telnet connected just fine

Note You need to log in before you can comment on or make changes to this bug.