Bug 16556 - unresolved symbols in parport_cs.o w/ 2.2.16-3
Summary: unresolved symbols in parport_cs.o w/ 2.2.16-3
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2EE
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-19 01:38 UTC by rudi
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-19 22:30:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rudi 2000-08-19 01:38:52 UTC
While attempting to rebuild kernel-2.2.16-3, I have found some unresolved
symbols in parport_cs.o:

[root@boh /root]# insmod parport_cs
Using /lib/modules/2.2.16-3/pcmcia/parport_cs.o
/lib/modules/2.2.16-3/pcmcia/parport_cs.o: unresolved symbol
register_pccard_driver
/lib/modules/2.2.16-3/pcmcia/parport_cs.o: unresolved symbol
unregister_pccard_driver
/lib/modules/2.2.16-3/pcmcia/parport_cs.o: unresolved symbol parport_pc_ops
/lib/modules/2.2.16-3/pcmcia/parport_cs.o: unresolved symbol CardServices

I tried investigating the issue some more, but I couldn't find the cause of
the problems. Unfortunately I haven't got that much experience with the
Linux kernel sources, let alone PCMCIA stuff. ;-(

Comment 1 Bill Nottingham 2000-08-19 22:30:39 UTC
Try modprobe instead of insmod.

Comment 2 Michael K. Johnson 2000-08-28 15:00:48 UTC
I think Bill is right, you want modprobe.


Note You need to log in before you can comment on or make changes to this bug.