Bug 1655623 - lorax-composer fails to build when only using CDN repo sources
Summary: lorax-composer fails to build when only using CDN repo sources
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: lorax
Version: 8.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Brian Lane
QA Contact: Release Test Team
Vladimír Slávik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 15:13 UTC by Ranjith Rajaram
Modified: 2019-06-14 01:41 UTC (History)
2 users (show)

Fixed In Version: lorax-28.14.18-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-14 01:41:29 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Lorax log files (209.85 KB, application/x-gzip)
2018-12-03 15:13 UTC, Ranjith Rajaram
no flags Details
var-lib-lorax-results dir (29.68 KB, application/x-gzip)
2018-12-03 16:09 UTC, Ranjith Rajaram
no flags Details

Description Ranjith Rajaram 2018-12-03 15:13:06 UTC
Created attachment 1510984 [details]
Lorax log files

Description of problem:

Composer fails with the following message:

Dec 03 09:29:55 localhost.localdomain lorax-composer[1579]: 2018-12-03 09:29:55,743: The exact error message is:
Dec 03 09:29:55 localhost.localdomain lorax-composer[1579]: 2018-12-03 09:29:55,743:
Dec 03 09:29:55 localhost.localdomain lorax-composer[1579]: 2018-12-03 09:29:55,743: The following mandatory spokes are not completed:
Dec 03 09:29:55 localhost.localdomain lorax-composer[1579]: 2018-12-03 09:29:55,743: Installation source
Dec 03 09:29:55 localhost.localdomain lorax-composer[1579]: 2018-12-03 09:29:55,743: Software selection.

# composer-cli compose status
2c011b81-41c6-49c6-bef1-3af1b504a49e FAILED   Mon Dec  3 09:54:56 2018 newcomposer     0.0.2 qcow2  

Attached the /var/log/lorax-composer/*.logs


Version-Release number of selected component (if applicable):
lorax-templates-rhel-8.0-19.el8.noarch
lorax-28.14.16-1.el8.x86_64
lorax-composer-28.14.16-1.el8.x86_64
lorax-lmc-novirt-28.14.16-1.el8.x86_64
lorax-templates-generic-28.14.16-1.el8.x86_64
[root@localhost ~]# 

How reproducible:
Always


Steps to Reproduce:
1. Install lorax-composer, cockpit etc
2. Attempt to create a qcow2 image
3.

Actual results:

Image creation fails

Expected results:

Image creation should succeed. 

Additional info:

Comment 2 Ranjith Rajaram 2018-12-03 16:09:52 UTC
Created attachment 1510996 [details]
var-lib-lorax-results dir

Comment 3 Ranjith Rajaram 2018-12-03 16:23:53 UTC
Closing the BZ as I notice multiple issues with the configuration. I should have used a custom repo

Comment 4 Brian Lane 2018-12-04 00:19:31 UTC
Let's use this to track making it more clear that lorax-composer doesn't support CDN only repo sources right now. We'll add a status message to 'composer-cli status show' and block starting a build if there aren't any non-CDN repos enabled.

Comment 5 Brian Lane 2018-12-04 00:40:10 UTC
https://github.com/weldr/lorax/pull/536

Comment 7 Alexander Todorov 2019-01-24 14:14:46 UTC
https://travis-ci.org/weldr/lorax/builds/483834721


Note You need to log in before you can comment on or make changes to this bug.