Bug 1655791 - Change fstab configuration for VDO volumes to add _netdev and device timeout [NEEDINFO]
Summary: Change fstab configuration for VDO volumes to add _netdev and device timeout
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Storage_Administration_Guide
Version: 7.6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Marek Suchánek
QA Contact: Zhang Kexin
URL:
Whiteboard:
: 1655781 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 22:59 UTC by Dennis Keefe
Modified: 2019-12-10 13:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-06 16:27:55 UTC
Target Upstream Version:
msuchane: needinfo?


Attachments (Terms of Use)

Description Dennis Keefe 2018-12-03 22:59:18 UTC
Document URL: 
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html-single/storage_administration_guide/index

Section Number and Name: 
29.3.3. Creating a VDO Volume

Describe the issue: 
XFS and EXT4 examples should be updated from
  "x-systemd.requires=vdo.service 0 0"



Suggestions for improvement: 

to
  "_netdev,x-systemd.device-timeout=0,x-systemd.requires=vdo.service"

Additional information:

Comment 2 Marek Suchánek 2018-12-04 18:09:21 UTC
(In reply to Dennis Keefe from comment #0)
> Document URL: 
> https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/
> html-single/storage_administration_guide/index
> 
> Section Number and Name: 
> 29.3.3. Creating a VDO Volume
> 
> Describe the issue: 
> XFS and EXT4 examples should be updated from
>   "x-systemd.requires=vdo.service 0 0"
> 
> 
> 
> Suggestions for improvement: 
> 
> to
>   "_netdev,x-systemd.device-timeout=0,x-systemd.requires=vdo.service"
> 
> Additional information:

I've fixed the mount options both in RHEL 7 and RHEL 8 Beta documentation. I assume the same edit was needed in both versions. Previews:

* 7: https://doc-stage.usersys.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/storage_administration_guide/vdo-quick-start#vdo-qs-creating-a-volume

* 8 Beta: https://doc-stage.usersys.redhat.com/documentation/en-us/red_hat_enterprise_linux/8-beta/html/deduplicating_and_compressing_storage/assembly_getting-started-with-vdo-deduplicating-and-compressing-storage#proc_creating-a-vdo-volume-getting-started-with-vdo

Is this correct now? If so, I'll republish the docs.

I notice the RHEL 7 procedure also suggests creating a systemd mount unit as an alternative to fstab. Do any of the new options need to be added there as well?

Comment 3 Marek Suchánek 2018-12-04 18:12:14 UTC
*** Bug 1655781 has been marked as a duplicate of this bug. ***

Comment 4 Marek Suchánek 2018-12-06 16:27:55 UTC
In our email conversation, we've agreed that the issue is now solved, so I'm closing this bug.


Note You need to log in before you can comment on or make changes to this bug.