Bug 165582 - Login hangs on NFS problems
Login hangs on NFS problems
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: util-linux (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 12:24 EDT by Alexander Spanke
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 06:53:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Spanke 2005-08-10 12:24:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
A cluster of 230+ nodes is sharing /usr/local/bin as a NFS share and this 
sharing of /usr/local/bin via NFS is mandatory. If we encounter NFS problems, 
login to the nodes for further analyses is not possible anymore out of the cause of the hardwired PATH=/usr/local/bin;/usr/local/sbin;... within the /bin/login binary.



Version-Release number of selected component (if applicable):
util-linux-2.11y-31.2

How reproducible:
Always

Steps to Reproduce:
1. Mount a NFS share under /usr/local/bin
2. Interrupt the NFS connection, i.e. stop the NFS server
3. Try to login to the Client host
  

Actual Results:  The login is hanging until the NFS share is back again ...

Expected Results:  We expect to be able to login to a system with NFS problems to start with investigations ...

Additional info:
Comment 1 Karel Zak 2005-08-29 04:37:30 EDT
Do you use mingetty as console tty handler? (See /etc/inittab). Are you sure
that you don't have anything important on NFS mount point? For example some
parts of PAM, log files, shells, things from shell profile or rc files or so.
Comment 2 Alexander Spanke 2005-08-29 05:05:56 EDT
(In reply to comment #1)
> Do you use mingetty as console tty handler? (See /etc/inittab). Are you sure
> that you don't have anything important on NFS mount point? For example some
> parts of PAM, log files, shells, things from shell profile or rc files or so.

With the mingetty, I will check ...
Regarding the important parts on NFS shares, we are working with a NFS share 
mounted under /usr/local/bin; there we only have our own scripts and 
applications, but during the login process, /usr/local/bin will be specified at 
the first position  of $PATH,and every lokkup, for  example for the 'id' 
command within startup scripts, will  end in a hanging situation, because the 
system trys to looks it up firstly in /usr/local/bin which is the NFS share. So 
with broken NFS servers, we are not even able tologin to the clients...
Comment 3 Karel Zak 2005-08-29 05:58:03 EDT
Yes, it's exactly what I've expected. You can try NFS mount with 'soft' option
instead 'hard' -- it will cause I/O error instead waiting on NFS. For details
see "man nfs". You can also change your PATH setting.

I think there it no bug. Your system only follows your settings :-)
Comment 4 Alexander Spanke 2005-08-29 06:03:43 EDT
Hi,

there is our problem, out of the applications enviroment, we cannot use soft 
mounts, we already discussed this :( 
For the path setup, we just changed it and removed the /usr/local/bin from the 
$PATH completely, but I didn't understand why /bin/login specified it directly 
in the beginning instead of adding /usr/local/... to the end, that's why I 
submitted this bug report.
Comment 5 Karel Zak 2005-08-29 06:34:08 EDT
It allows users to use their own programs from /usr/local/bin instead system
default things. I'm sure that we don't want to change it.

You can try define your own PATH on begin of /etc/profile.


Comment 6 Alexander Spanke 2005-08-29 06:53:13 EDT
Oh, that's the reason, I thought using the system binaries should be first ...

I will close the bug now, as it is not a bug at all;)

Thanks a lot for your help !! 

Note You need to log in before you can comment on or make changes to this bug.