Bug 1655984 - lvm2.lvmdump-am plugin option is ignored
Summary: lvm2.lvmdump-am plugin option is ignored
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: sos
Version: 8.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: 8.0
Assignee: Pavel Moravec
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 11:29 UTC by Pavel Moravec
Modified: 2019-06-13 23:00 UTC (History)
6 users (show)

Fixed In Version: sos-3.6-8.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-13 23:00:43 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github sosreport sos issues 1498 0 None None None 2018-12-04 11:29:50 UTC

Description Pavel Moravec 2018-12-04 11:29:51 UTC
Description of problem:
See https://github.com/sosreport/sos/issues/1498 for details.


Version-Release number of selected component (if applicable):
sos-3.6-7.el8.noarch


How reproducible:
100%


Steps to Reproduce:
1.
sosreport -o lvm2 --tmp-dir=. --batch -k lvm2.lvmdump-am=on --build -v

2.
Check if "lvmdump -a -m" command output is collected (sos_commands/lvm2/lvmdump_-a_-m_* file and sos_commands/lvm2/lvmdump directory to be created)


Actual results:
2. not collected; -k lvm2.lvmdump=on collects a different lvmdump but without metadata


Expected results:
2. to collect lvmdump with metadata, -k lvm2.lvmdump=on to collect lvmdump without metadata


Additional info:
in general: the problem is when a plugin option is a prefix of another option of the same plugin (this option is evaluated according to the "prefixed option", instead)


Note You need to log in before you can comment on or make changes to this bug.