Bug 1655993 - Unable to update Undertow Host resource configuration
Summary: Unable to update Undertow Host resource configuration
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7
Version: JON 3.3.11
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Simeon Pinder
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 11:49 UTC by Filip Brychta
Modified: 2018-12-04 11:52 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-04 11:52:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Filip Brychta 2018-12-04 11:49:00 UTC
Description of problem:
Attempt to update Undertow Host resource configuration fails with:
Operation  returned unparsable JSON, <"">., rolled-back=false


Version-Release number of selected component (if applicable):
JON 3.3.11 + EAP plugin pack 08.CR01

How reproducible:
Always

Steps to Reproduce:
1. start EAP 7.2 standalone
2. import the EAP 7 standalone from discovery queue
3. run Install RHQ User operation
4. navigate to EAP 7->Subsystems->Web->undertow->default-server->default-host->Configuration
5. set Disable Console Redirect to Yes
6. Save

Actual results:
Updated failed with:
Operation  returned unparsable JSON, <"">., rolled-back=false

Expected results:
Update is successful.

Additional info:
Visible only on EAP 7.2 not on EAP 7.1

Comment 1 Filip Brychta 2018-12-04 11:52:39 UTC
The issue is not visible after EAP restart. EAP was probably in some inconsistent state -> closing.


Note You need to log in before you can comment on or make changes to this bug.