Bug 165603 - i586 gfs-related kernel module packages appear to be compiled for i686
i586 gfs-related kernel module packages appear to be compiled for i686
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: GFS-kernel (Show other bugs)
4
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Feist
:
: 162763 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 14:44 EDT by Kristian Hoffmann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 17:01:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kristian Hoffmann 2005-08-10 14:44:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.9) Gecko/20050720 Firefox/1.0.5

Description of problem:
The GFS-related kernel module packages (GFS-kernel, dlm-kernel, cman-kernel, and gndb-kernel) that are marked for the i586 arch appear to be compiled for i686 instead.


Version-Release number of selected component (if applicable):
GFS-kernel-2.6.11.8-20050601.152643.FC4.9

How reproducible:
Always

Steps to Reproduce:
1. yum install gfs-kernel
2. modprobe gfs
3.
  

Actual Results:  lock_harness: version magic '2.6.12-1.1398_FC4 686 REGPARM 4KSTACKS gcc-4.0' should be '2.6.12-1.1398_FC4 586 REGPARM 4KSTACKS gcc-4.0'
gfs: version magic '2.6.12-1.1398_FC4 686 REGPARM 4KSTACKS gcc-4.0' should be '2.6.12-1.1398_FC4 586 REGPARM 4KSTACKS gcc-4.0'

Expected Results:  The modules (compiled for 586) should have loaded.

Additional info:

Here are the kernel messages when trying to load any of these modules on a i586...

gfs: version magic '2.6.12-1.1398_FC4 686 REGPARM 4KSTACKS gcc-4.0' should be '2.6.12-1.1398_FC4 586 REGPARM 4KSTACKS gcc-4.0'

lock_harness: version magic '2.6.12-1.1398_FC4 686 REGPARM 4KSTACKS gcc-4.0' should be '2.6.12-1.1398_FC4 586 REGPARM 4KSTACKS gcc-4.0'

cman: version magic '2.6.12-1.1398_FC4 686 REGPARM 4KSTACKS gcc-4.0' should be '2.6.12-1.1398_FC4 586 REGPARM 4KSTACKS gcc-4.0'

dlm: version magic '2.6.12-1.1398_FC4 686 REGPARM 4KSTACKS gcc-4.0' should be '2.6.12-1.1398_FC4 586 REGPARM 4KSTACKS gcc-4.0'

lock_dlm: version magic '2.6.12-1.1398_FC4 686 REGPARM 4KSTACKS gcc-4.0' should be '2.6.12-1.1398_FC4 586 REGPARM 4KSTACKS gcc-4.0'

gnbd: version magic '2.6.12-1.1398_FC4 686 REGPARM 4KSTACKS gcc-4.0' should be '2.6.12-1.1398_FC4 586 REGPARM 4KSTACKS gcc-4.0'


From an extracted GFS-kernel-2.6.11.8-20050601.152643.FC4.2.i586.rpm...
khoff@ugy ~/Tmp/gfs $ strings ./lib/modules/2.6.11-1.1369_FC4/kernel/fs/gfs/gfs.ko|grep 686
vermagic=2.6.11-1.1369_FC4 686 REGPARM 4KSTACKS gcc-4.0

The same can be observed with all other GFS-related kernel modules listed above.
Comment 1 Kristian Hoffmann 2005-08-10 17:52:57 EDT
It looks like the specfile for these packages ignores the target architecture
and builds the kernel modules against the sources in /lib/modules/`uname
-r`/build/.  If the build system is an i686, then you get i686 modules
regardless of the --target argument passed to rpmbuild.
Comment 2 Chris Feist 2005-12-12 17:45:43 EST
I've confirmed this issue and am working on a fix.
Comment 3 Chris Feist 2006-09-29 17:01:49 EDT
Due to issues in the build process we are unable to build i586 packages at this
time.
Comment 4 Chris Feist 2006-09-29 17:04:00 EDT
*** Bug 162763 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.