This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 165684 - French manpages are in German
French manpages are in German
Status: CLOSED DUPLICATE of bug 165701
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-tools (Show other bugs)
4.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
RHEL4U3NAK
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 08:01 EDT by Blue Dwarf
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-13 14:52:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Blue Dwarf 2005-08-11 08:01:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

Description of problem:
If you use french man pages, the net-tools package install french man pages of ifconfig, netstat, route ... as well as english man pages (and other language man pages). If your environment variable LANG is set to FR, man ifconfig should give french man page of ifconfig. It gives you german man page. If LANG is set to EN, you get english man pages.

Version-Release number of selected component (if applicable):
net-tools-1.60-37.EL4.6

How reproducible:
Always

Steps to Reproduce:
1.install french man pages
2.set default language to french (LANG=fr_FR.UTF-8)
3.install net-tools package
3.man ifconfig
  

Actual Results:  Issuing a "man ifconfig" gives the right man page but in german, instead of french

Expected Results:  You should have the french man page of ifconfig

Additional info:

The bug is a problem with the spec file of the rpm package. I have a patch that can solve the problem. In the spec file, german man pages are moved to the french man pages directory. They should be placed in the german man pages directory. Here is the patch (if you think it could be usefull) :
-------Start of the patch file-------
--- net-tools.spec.old	2005-08-09 15:20:03.047368872 +0200
+++ net-tools.spec	2005-08-09 15:21:44.062012312 +0200
@@ -120,15 +120,15 @@
 iconv -f iso-8859-1 -t utf-8 -o rarp.tmp man/pt_BR/rarp.8 && mv rarp.tmp man/pt_BR/rarp.8
 iconv -f iso-8859-1 -t utf-8 -o route.tmp man/pt_BR/route.8 && mv route.tmp man/pt_BR/route.8
 #german
-iconv -f iso-8859-1 -t utf-8 -o arp.tmp man/de_DE/arp.8 && mv arp.tmp man/fr_FR/arp.8
-iconv -f iso-8859-1 -t utf-8 -o ethers.tmp man/de_DE/ethers.5 && mv ethers.tmp man/fr_FR/ethers.5
-iconv -f iso-8859-1 -t utf-8 -o hostname.tmp man/de_DE/hostname.1 && mv hostname.tmp man/fr_FR/hostname.1
-iconv -f iso-8859-1 -t utf-8 -o ifconfig.tmp man/de_DE/ifconfig.8 && mv ifconfig.tmp man/fr_FR/ifconfig.8
-iconv -f iso-8859-1 -t utf-8 -o netstat.tmp man/de_DE/netstat.8 && mv netstat.tmp man/fr_FR/netstat.8
-iconv -f iso-8859-1 -t utf-8 -o plipconfig.tmp man/de_DE/plipconfig.8 && mv plipconfig.tmp man/fr_FR/plipconfig.8
-iconv -f iso-8859-1 -t utf-8 -o rarp.tmp man/de_DE/rarp.8 && mv rarp.tmp man/fr_FR/rarp.8
-iconv -f iso-8859-1 -t utf-8 -o route.tmp man/de_DE/route.8 && mv route.tmp man/fr_FR/route.8
-iconv -f iso-8859-1 -t utf-8 -o slattach.tmp man/de_DE/slattach.8 && mv slattach.tmp man/fr_FR/slattach.8
+iconv -f iso-8859-1 -t utf-8 -o arp.tmp man/de_DE/arp.8 && mv arp.tmp man/de_DE/arp.8
+iconv -f iso-8859-1 -t utf-8 -o ethers.tmp man/de_DE/ethers.5 && mv ethers.tmp man/de_DE/ethers.5
+iconv -f iso-8859-1 -t utf-8 -o hostname.tmp man/de_DE/hostname.1 && mv hostname.tmp man/de_DE/hostname.1
+iconv -f iso-8859-1 -t utf-8 -o ifconfig.tmp man/de_DE/ifconfig.8 && mv ifconfig.tmp man/de_DE/ifconfig.8
+iconv -f iso-8859-1 -t utf-8 -o netstat.tmp man/de_DE/netstat.8 && mv netstat.tmp man/de_DE/netstat.8
+iconv -f iso-8859-1 -t utf-8 -o plipconfig.tmp man/de_DE/plipconfig.8 && mv plipconfig.tmp man/de_DE/plipconfig.8
+iconv -f iso-8859-1 -t utf-8 -o rarp.tmp man/de_DE/rarp.8 && mv rarp.tmp man/de_DE/rarp.8
+iconv -f iso-8859-1 -t utf-8 -o route.tmp man/de_DE/route.8 && mv route.tmp man/de_DE/route.8
+iconv -f iso-8859-1 -t utf-8 -o slattach.tmp man/de_DE/slattach.8 && mv slattach.tmp man/de_DE/slattach.8
 
 
 %build
-------End of the patch file-------
I applied this patch, rebuild the rpm package and installed it. Then, everything works fine.
Comment 1 Radek Vokal 2005-08-11 08:50:16 EDT
Fixed already in rawhide but thanks for the patch anyway. Will get fixed in one
of upcomming updates. 
Comment 5 Daniel Riek 2006-03-13 14:52:16 EST

*** This bug has been marked as a duplicate of 165701 ***

Note You need to log in before you can comment on or make changes to this bug.