Bug 1657035 - RFE: update python-werkzeug to 0.11 or newer [NEEDINFO]
Summary: RFE: update python-werkzeug to 0.11 or newer
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-werkzeug
Version: 7.6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: John Keck
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-06 21:50 UTC by Mason Loring Bliss
Modified: 2020-05-07 11:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-07 11:38:57 UTC
Target Upstream Version:
chhudson: needinfo? (jkeck)
chhudson: needinfo? (jkeck)


Attachments (Terms of Use)

Description Mason Loring Bliss 2018-12-06 21:50:31 UTC
1. Proposed title of this feature request

RFE: update python-werkzeug to 0.11 or newer


2. Who is the customer behind the request?

Account: Netezza 291555
TAM customer: yes
CSM customer: no
Strategic: yes


3. What is the nature and description of the request?

RFE: update python-werkzeug to 0.11 or newer


4. Why does the customer need this? (List the business requirements here)

From customer:

The problem is that older version of werkzeug (0.9.1) uses SSL context objects from external `OpenSSL` package and those objects does not support configuration of allowing only TLS 1.2 connections. Newer werkzeug (0.11) uses SSL context objects from python built-in `ssl` package and those allow such configuration.


5. How would the customer like to achieve this? (List the functional requirements here)

Update python-werkzeug to the noted version or backport functionality.


6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.

Customer can build against new version, see TLS limits enforced.


7. Is there already an existing RFE upstream or in Red Hat Bugzilla?

No.


8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?

RHEL 7, when possible


9. Is the sales team involved in this request and do they have any additional input?

No.


10. List any affected packages or components.

python-werkzeug


11. Would the customer be able to assist in testing this functionality if implemented?

Yes.

Comment 7 Josh Boyer 2020-05-07 11:38:49 UTC
RHEL 7 has entered Maintenance Support phase and will no longer receive new Features or rebased packages.

Comment 8 RHEL Program Management 2020-05-07 11:38:57 UTC
Product Management has reviewed and declined this request.
You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.