Bug 165710 - rpmbuild fails to find ia32e arch macros
rpmbuild fails to find ia32e arch macros
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
4
ia32e Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 10:08 EDT by Tim Fletcher
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-25 13:28:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Fletcher 2005-08-11 10:08:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
while trying to rebuild openvpn-2.0-1.rf.src.rpm on an ia32e host (install in 64bit mode) the rpm fails to build with the following error:

 RPM build errors:
    File must begin with "/": %{_initrddir}/openvpn

and running rpm --showrc | grep initrd doesn't show anything

This can be fixed by running the following command:

cd /usr/lib/rpm
ln -s x86_64-linux ia32e-linux

rpm --showrc and the rpmbuild command works as expected.

I'm not sure that this is the correct fix but it "Works for me" tm

Version-Release number of selected component (if applicable):
rpm-4.4.1-22

How reproducible:
Always

Steps to Reproduce:
1. Install ia32e host in 64bit mode (bare install)
2. Install rpmbuild 
3. Try to build openvpn rpm
  

Actual Results:  rpmbuild failed

Expected Results:  an openvpn binary rpm

Additional info:
Comment 1 Jeff Johnson 2005-08-25 13:28:10 EDT
For *.rpm purposes, the arch is "x86_64", not "ia32e".

Note You need to log in before you can comment on or make changes to this bug.