Bug 165712 - Clicking open dialog (gtkfilechooser), gtk2 crashes
Clicking open dialog (gtkfilechooser), gtk2 crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
: 165969 166050 166071 166103 166104 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 10:20 EDT by sangu
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-16 07:59:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gedit bactrace file (12.22 KB, text/plain)
2005-08-11 10:20 EDT, sangu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 310270 None None None Never

  None (edit)
Description sangu 2005-08-11 10:20:02 EDT
Description of problem:
Clicking open dialog (gtkfilechooser), gtk2 crashes on gnome-vfs2-2.11.90-2

Version-Release number of selected component (if applicable):
gnome-vfs2-2.11.90-2


How reproducible:
always

Steps to Reproduce:
1. Execute gtk2 program (like gedit )
2. Click opendialog (gtkfilechooser)
3.
  
Actual results:


Expected results:


Additional info:
gtk2-2.7.5-1, glib2-2.7.6-3
Comment 1 sangu 2005-08-11 10:20:02 EDT
Created attachment 117647 [details]
gedit bactrace file
Comment 2 sangu 2005-08-11 10:23:58 EDT
in openoffice.org-1.9.123-1.2.0.fc5

0x3abb8a: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db8a
0x3ac3d8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3d8
0xcfb420:  + 0x420 (__kernel_sigreturn + 0x0)
0x475c550: /usr/lib/libgtk-x11-2.0.so.0 + 0xd5550
0x474a9ef: /usr/lib/libgtk-x11-2.0.so.0 + 0xc39ef
0x4760a06: /usr/lib/libgtk-x11-2.0.so.0 + 0xd9a06
0x474a9ef: /usr/lib/libgtk-x11-2.0.so.0 + 0xc39ef
0x4760a06: /usr/lib/libgtk-x11-2.0.so.0 + 0xd9a06
0x474a9ef: /usr/lib/libgtk-x11-2.0.so.0 + 0xc39ef
0x474aff3: /usr/lib/libgtk-x11-2.0.so.0 + 0xc3ff3
(gtk_file_chooser_set_current_folder_uri + 0x7a)
0x77d4dfd: /usr/lib/openoffice.org2.0/program/fps_gnome.uno.so + 0x7dfd
0x77d596b: /usr/lib/openoffice.org2.0/program/fps_gnome.uno.so + 0x896b
0x334e2e9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c62e9
0x334f44f: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c744f
0x3351a97: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c9a97
0x3351af5: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c9af5
0x3351edf: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c9edf
0x3352663: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ca663
(sfx2::FileDialogHelper::Execute(String const&, SvStringsDtor*&, SfxItemSet*&,
String&) + 0x2f)
0x335410a: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1cc10a
0x3220ef7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x98ef7
0x3227dd0: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x9fdd0
0x331e9da: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1969da
0x331ddc7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x195dc7
0x331e0db: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1960db
0x331e17e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19617e
0x321f312: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x97312
0x33370dd: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1af0dd
0x3336f98: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aef98
0x33370f2: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1af0f2
0x3336f84: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aef84
0x9d3842: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x7a842
0xb285fb: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1cf5fb
0x11bee72: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1ee72
0x11e40cd: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x440cd
(SalDisplay::DispatchInternalEvent() + 0xad)
0x1183a73: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xaa73
0x67662ee: /usr/lib/libglib-2.0.so.0 + 0x272ee
0x676407e: /usr/lib/libglib-2.0.so.0 + 0x2507e (g_main_context_dispatch + 0x1dc)
0x6767096: /usr/lib/libglib-2.0.so.0 + 0x28096
0x6767578: /usr/lib/libglib-2.0.so.0 + 0x28578 (g_main_context_iteration + 0x66)
0x1183699: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa699
0x11e5d99: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45d99
(X11SalInstance::Yield(unsigned char) + 0x29)
0x9d9ba4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x80ba4
(Application::Yield() + 0x50)
0x9d9be2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x80be2
(Application::Execute() + 0x26)
0x80656ac: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1d6ac
(desktop::Desktop::Main() + 0x149a)
0x9defd1: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x85fd1 (SVMain()
+ 0x45)
0x806075f: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1875f (sal_main +
0x47)
0x5e5e49f: /lib/libc.so.6 + 0x1549f (__libc_start_main + 0xdf)
0x8060695: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18695
(Window::RequestHelp(HelpEvent const&) + 0x31)


After installing gnome-vfs2-2.11.90-2, this problems happen.
Comment 3 sangu 2005-08-14 12:19:38 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=310270

in GTK+ 2.8 Changlog 
2005-08-11  Matthias Clasen  <mclasen@redhat.com>

	* gtk/gtkfilechooserdefault.c: Work around some problems
	with the gnome-vfs backends which could lead to crashes
	in the bookmark handling.  (#310270, Diego Gonzalez, patch
	by Michael Meeks)

Updating to gtk2-2.8.0, this problem seems to be fixed.

So, please update to gtk2-2.8.0
Comment 4 Caolan McNamara 2005-08-15 13:17:27 EDT
*** Bug 165969 has been marked as a duplicate of this bug. ***
Comment 5 Rahul Sundaram 2005-08-15 13:29:19 EDT
sangu,

Thank you for the report. GTK 2.8 should reach rawhide along with the rest of
the GNOME updates shortly
Comment 6 Rahul Sundaram 2005-08-16 06:06:39 EDT
*** Bug 166050 has been marked as a duplicate of this bug. ***
Comment 7 Matthias Clasen 2005-08-16 07:59:11 EDT
2.8.0 is in rawhide now
Comment 8 Caolan McNamara 2005-08-17 04:08:40 EDT
*** Bug 166104 has been marked as a duplicate of this bug. ***
Comment 9 Caolan McNamara 2005-08-17 04:45:47 EDT
*** Bug 166103 has been marked as a duplicate of this bug. ***
Comment 10 Alexandre Oliva 2005-08-20 12:01:46 EDT
*** Bug 166071 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.