Bug 165751 - scanning support missing after installing hplilp
scanning support missing after installing hplilp
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 15:31 EDT by Matt Emmett
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 09:05:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Emmett 2005-08-11 15:31:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I am not sure if this is a bug or not, but I would think that libsane-hpaio should be a dependancy of hplip.  I spent a great deal of time trying to figure out why I was getting an error when trying to use sane with my Officejet 7300.  Turning debugging on and running scanimage -L showed the missing sane backend.

Version-Release number of selected component (if applicable):
hplip-0.9.4-1.1 libsane-hpaio-0.9.4-1.1

How reproducible:
Always

Steps to Reproduce:
1.yum --enablerepo=updates-testing install hplip
2.Install printer via cups web interface(couldn't get system-config-printer to work for a network printer)
3.Open xsane
  

Actual Results:  xsane could not find any devices because hpaio sand backend is missing

Expected Results:  Should have been able to scan after installing hplip

Additional info:
Comment 1 Tim Waugh 2005-09-06 05:26:03 EDT
I saw a suggestion on fedora-list that sane-backends should just require
libsane-hpaio.

Nils, what do you think about making that change for FC5 onwards?  The
requirement is not a necessity, but this problem comes up frequently enough that
it would avoid a lot of problems to just make libsane-hpaio a requirement.
Comment 2 Nils Philippsen 2005-09-19 03:10:30 EDT
Barring unforeseen improvements in the realm of RPM requirements, this sounds
like the sane approach to me (no pun intended).
Comment 3 Nils Philippsen 2006-06-07 09:05:44 EDT
fixed in sane-backends-1.0.17-12

Note You need to log in before you can comment on or make changes to this bug.