Bug 165773 - inn package from fc4 cannot be installed
inn package from fc4 cannot be installed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: inn (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
: 165774 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 18:44 EDT by Filip Miletic
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 10:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Miletic 2005-08-11 18:44:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; sr-YU; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
The package won't install with the following message:

The following packages have unmet dependencies:
  inn: Depends: /usr/lib/news/lib/innshellvars.pl but it is not installable
E: Broken packages

(I use apt-get to install, but this should not matter)

Version-Release number of selected component (if applicable):
inn-2.4.2-3

How reproducible:
Always

Steps to Reproduce:
1. Try to install the appropriate inn package

Actual Results:  The error message prints.

Expected Results:  The package should have been instaled.

Additional info:
Comment 1 Filip Miletic 2005-08-11 19:06:42 EDT
*** Bug 165774 has been marked as a duplicate of this bug. ***
Comment 2 Martin Stransky 2005-08-15 10:18:14 EDT
It's a bug in apt-get, because inn provides innshellvars.pl:

$rpm -qp --provides inn-2.4.2-3.i386.rpm | grep pl
perl(::usr/lib/innshellvars.pl)

$rpm -qp --requires inn-2.4.2-3.i386.rpm | grep pl
/usr/lib/news/lib/innshellvars.pl
perl(bigint.pl)
perl(ftp.pl)
perl(getopts.pl)

It works fine with yum and rpm...

Note You need to log in before you can comment on or make changes to this bug.