This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 165777 - Error in /etc/audit.rules line 5 reported at boot time
Error in /etc/audit.rules line 5 reported at boot time
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Steve Grubb
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-11 19:57 EDT by J. Erik Hemdal
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.0.2-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-16 07:09:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description J. Erik Hemdal 2005-08-11 19:57:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
I receive the messages

Error sending rule list request (Invalid argument)
Error in line 5 of /etc/audit.rules

at boot time when starting auditd.

Stock FC4 installation with all updates applied on Dell Inspiron 1100 laptop.
I've made no changes to any of the files since installation of FC4.  SELinux is set to "Warn".

Version data:

audit-libs-0.9.19-2.FC4
audit-0.9.19-2.FC4

Contents of /etc/audit.rules:
=============================
# This file contains the auditctl rules that are loaded
# whenever the audit daemon is started via the initscripts.

# First rule - delete all
-D

# Feel free to add below this line. See auditctl man page

# Increase the buffers to survive stress events
-b 256


Version-Release number of selected component (if applicable):
audit-0.9.19-2.FC4

How reproducible:
Always

Steps to Reproduce:
1.Boot the computer and watch messages after auditd starts.
2.
3.
  

Actual Results:  Message appears.

Expected Results:  No messages.

Additional info:

This appears to be a minor issue, but it suggests a low-quality release if the system delivers errors after an out-of-the-box installation.  I have had no ill effects.
Comment 1 Steve Grubb 2005-08-12 07:12:04 EDT
This only occurs when you have SE Linux disabled. Have you tried updating to
1.0.2-3? Just released yesterday.
Comment 2 Dusko Dobranic 2005-08-16 06:42:51 EDT
kernel 2.6.12-1.1398_FC4
audit-libs-1.0.2-3.FC4
audit-1.0.2-3.FC4

When I execute auditctl -D I get:

No rules
File system watches not supported
Comment 3 Steve Grubb 2005-08-16 07:09:42 EDT
Thanks. Closing based on positive feedback.
Comment 4 J. Erik Hemdal 2005-08-16 09:07:05 EDT
I haven't seen the new audit via yum yet.  When I get it I will try this. 
Comment 5 Steve Grubb 2005-08-16 09:29:07 EDT
It's been available for 4 days. Mirrors should have sync'ed by now.

http://mirrors.kernel.org/fedora/core/updates/4/

Hope this helps.
Comment 6 J. Erik Hemdal 2005-08-16 20:17:03 EDT
Fixed by applying audit-1.0.2-3-FC4.

Note You need to log in before you can comment on or make changes to this bug.