Bug 16585 - Can't mount CD with magicdev enabled
Summary: Can't mount CD with magicdev enabled
Status: CLOSED DUPLICATE of bug 15346
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: magicdev   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-19 15:55 UTC by Dale Lovelace
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-19 16:01:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dale Lovelace 2000-08-19 15:55:02 UTC
Ok, this is complicated...

reboot
Start X with magicdev enabled and no cd in drive		can't mount cdrom
	kill magicdev				can't mount cdrom
	exit X					can't mount cdrom

reboot
Startx X with magicdev enabled and cd in drive		can mount cdrom
	kill magicdev				can mount cdrom
	exit X					can mount cdrom

reboot
Startx X with magicdev enabled and a cd already mounted
	umount cdrom the attempt to remount		can mount cdrom
	kill magicdev				can mount cdrom
	exit X					can mount cdrom

reboot
Start X with no magicdev				can mount cdrom

  When the attempt to mount the cdron fails I get this message:

mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (aren't you trying to mount an extended partition,
       instead of some logical partition inside?)

  When exiting an X session that had magicdev enabled, and cause the mount
to fail, I can kill magicdev and eject/reinsert the cdrom and cause to
mount properly.

  I have attempted this on several machines. I have only been able to
reproduce it on machines with an Asus P3B motherboard.

Comment 1 Elliot Lee 2000-08-21 18:38:57 UTC

*** This bug has been marked as a duplicate of 15346 ***


Note You need to log in before you can comment on or make changes to this bug.