This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 165852 - xml error when querying
xml error when querying
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-12 16:54 EDT by Nick Trown
Modified: 2013-04-02 00:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 10:28:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
resulting document showing problem (458 bytes, text/plain)
2005-08-16 12:50 EDT, Nick Trown
no flags Details

  None (edit)
Description Nick Trown 2005-08-12 16:54:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

Description of problem:
When I try to access our internal bugzilla I get an error. The eclipse error log shows the following.

It mentions that it might because the bugzilla version is not supported.  If this the case what versions are supported?  I didn't see any mention of what the supported version are...

Error 2005-08-12 13:48:30.287 Error fetching query http://bugz/cgi-bin/bugzilla/buglist.cgi?&product=ActiveNet&search=Search&chfieldto=Now&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&version=v3.2&format=rdf: Could not interpret the received data. Maybe the Bugzilla URL is invalid or the Bugzilla version is not supported.
org.eclipse.team.bugzilla.BugzillaException[102]: org.xml.sax.SAXParseException: Missing whitespace before SYSTEM literal URI.
	at org.apache.crimson.parser.Parser2.fatal(Parser2.java:3376)
	at org.apache.crimson.parser.Parser2.fatal(Parser2.java:3370)
	at org.apache.crimson.parser.Parser2.whitespace(Parser2.java:736)
	at org.apache.crimson.parser.Parser2.maybeExternalID(Parser2.java:2922)
	at org.apache.crimson.parser.Parser2.maybeDoctypeDecl(Parser2.java:1309)
	at org.apache.crimson.parser.Parser2.parseInternal(Parser2.java:656)
	at org.apache.crimson.parser.Parser2.parse(Parser2.java:337)
	at org.apache.crimson.parser.XMLReaderImpl.parse(XMLReaderImpl.java:448)
	at javax.xml.parsers.SAXParser.parse(SAXParser.java:345)
	at org.eclipse.team.bugzilla.xml.Parser.parse(Parser.java:36)
	at org.eclipse.team.bugzilla.operations.BugzillaOperations.getVersion(BugzillaOperations.java:81)
	at org.eclipse.team.bugzilla.operations.BugzillaOperations.getOperations(BugzillaOperations.java:43)
	at org.eclipse.team.bugzilla.operations.CachedOperations.getOperations(CachedOperations.java:93)
	at org.eclipse.team.bugzilla.operations.CachedOperations.getQueryData(CachedOperations.java:58)
	at org.eclipse.team.bugzilla.datatypes.DataCache.refreshQuery(DataCache.java:191)
	at org.eclipse.team.bugzilla.model.BugzillaQuery.refresh(BugzillaQuery.java:80)
	at org.eclipse.team.bugzilla.operations.RefreshOperation.fetch(RefreshOperation.java:159)
	at org.eclipse.team.bugzilla.operations.RefreshOperation.fetchElement(RefreshOperation.java:137)
	at org.eclipse.team.bugzilla.operations.RefreshOperation.run(RefreshOperation.java:122)
	at org.eclipse.team.bugzilla.view.DelayedRefreshPresenter.doDispatchEvents(DelayedRefreshPresenter.java:66)
	at org.eclipse.team.internal.core.BackgroundEventHandler.dispatchEvents(BackgroundEventHandler.java:354)
	at org.eclipse.team.internal.core.BackgroundEventHandler.processEvents(BackgroundEventHandler.java:334)
	at org.eclipse.team.internal.core.BackgroundEventHandler$1.run(BackgroundEventHandler.java:173)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)



Version-Release number of selected component (if applicable):
0.1.1

How reproducible:
Always

Steps to Reproduce:
1.enter new query
2.try to get results
3.
  

Additional info:
Comment 1 Jeff Pound 2005-08-16 10:59:22 EDT
Bugzilla 2.6 -> 2.8 is supported.

you can browse to http://bugz/cgi-bin/bugzilla/xml.cgi?id=1 and look for
"<bugzilla version=" in the top line to see what version you have installed.
Comment 2 Nick Trown 2005-08-16 12:02:57 EDT
We have 2.16.4 installed.  2.8 is pretty old, from 1999.  Is there any plans to
update the eclipse-bugzilla plug-in?
Comment 3 Jeff Pound 2005-08-16 12:30:55 EDT
Sorry, that was a typo. I meant 2.16 -> 2.18. So your version is supported.

>org.xml.sax.SAXParseException: Missing whitespace before SYSTEM literal URI.

It looks like the xml parser is choking, I'll see if there is any way I can
reproduce this. Connecting to web hosted 2.16.* bugzilla dbs works fine (ex:
http://bugzilla.kernel.org ).
Comment 4 Nick Trown 2005-08-16 12:50:30 EDT
Created attachment 117794 [details]
resulting document showing problem
Comment 5 Nick Trown 2005-08-16 12:51:57 EDT
Ah good :-)

I tried accessing all the bug systems that are listed in the pull-down and they
are all working fine.

Using the query that the plugin query builder built I'm attaching the resulting
document that is causing the parser to have problems.  Hope that helps.
Comment 6 Red Hat Bugzilla 2007-09-11 00:05:00 EDT
User klee@redhat.com's account has been closed
Comment 7 Andrew Overholt 2007-09-11 10:28:44 EDT
We are now shipping Mylyn which obsoletes the old bugzilla plugin.  Please open
a request at bugs.eclipse.org against Mylyn if this issue persists.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.