Bug 165882 - dhcp6c failed: interface eth0 iaid failed to be created
dhcp6c failed: interface eth0 iaid failed to be created
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcpv6 (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 166505
  Show dependency treegraph
 
Reported: 2005-08-13 11:09 EDT by Peter Bieringer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: dhcpv6-0.10-14_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 14:04:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2005-08-13 11:09:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
Trying to use dhcp6c on a client without an assigned IPv4 address to an interface won't work.

Version-Release number of selected component (if applicable):
dhcpv6_client-0.10-13

How reproducible:
Always

Steps to Reproduce:
1. dhcp6c -d -D -f eth0
  

Actual Results:  Aug/13/2005 17:05:56 <3>[interface] (9)
Aug/13/2005 17:05:56 <5>[eth0] (4)
Aug/13/2005 17:05:56 <3>begin of closure [{] (1)
Aug/13/2005 17:05:56 <3>comment [#      information-only;] (19)
Aug/13/2005 17:05:56 <3>[send] (4)
Aug/13/2005 17:05:56 <3>[rapid-commit] (12)
Aug/13/2005 17:05:56 <3>end of sentence [;] (1)
Aug/13/2005 17:05:56 <3>[request] (7)
Aug/13/2005 17:05:56 <3>[prefix-delegation] (17)
Aug/13/2005 17:05:56 <3>end of sentence [;] (1)
Aug/13/2005 17:05:56 <3>[iaid] (4)
Aug/13/2005 17:05:56 <3>[11111] (5)
Aug/13/2005 17:05:56 <3>end of sentence [;] (1)
Aug/13/2005 17:05:56 <3>comment [#      request temp-address;] (23)
Aug/13/2005 17:05:56 <3>end of closure [}] (1)
Aug/13/2005 17:05:56 <3>end of sentence [;] (1)
Aug/13/2005 17:05:56 extracted an existing DUID from /var/lib/dhcpv6/dhcp6c_duid: 00:01:00:01:0a:90:bb:f0:00:00:39:01:23:45
Aug/13/2005 17:05:56 link local addr is fe80::200:39ff:fe01:2345
Aug/13/2005 17:05:56 res addr is fe80::200:39ff:fe01:2345%eth0/28
Aug/13/2005 17:05:56  found an interface eth0 hardware 0xbfda77f5
Aug/13/2005 17:05:56 interface eth0 iaid failed to be created


Expected Results:  Working, like happen, if interface contain at least one IPv4 address (127.0.0.1 would work...).

Aug/13/2005 17:05:39 <3>[interface] (9)
Aug/13/2005 17:05:39 <5>[eth0] (4)
Aug/13/2005 17:05:39 <3>begin of closure [{] (1)
Aug/13/2005 17:05:39 <3>comment [#      information-only;] (19)
Aug/13/2005 17:05:39 <3>[send] (4)
Aug/13/2005 17:05:39 <3>[rapid-commit] (12)
Aug/13/2005 17:05:39 <3>end of sentence [;] (1)
Aug/13/2005 17:05:39 <3>[request] (7)
Aug/13/2005 17:05:39 <3>[prefix-delegation] (17)
Aug/13/2005 17:05:39 <3>end of sentence [;] (1)
Aug/13/2005 17:05:39 <3>[iaid] (4)
Aug/13/2005 17:05:39 <3>[11111] (5)
Aug/13/2005 17:05:39 <3>end of sentence [;] (1)
Aug/13/2005 17:05:39 <3>comment [#      request temp-address;] (23)
Aug/13/2005 17:05:39 <3>end of closure [}] (1)
Aug/13/2005 17:05:39 <3>end of sentence [;] (1)
Aug/13/2005 17:05:39 extracted an existing DUID from /var/lib/dhcpv6/dhcp6c_duid: 00:01:00:01:0a:90:bb:f0:00:00:39:01:23:45
Aug/13/2005 17:05:39 link local addr is fe80::200:39ff:fe01:2345
Aug/13/2005 17:05:39 res addr is fe80::200:39ff:fe01:2345%eth0/28
Aug/13/2005 17:05:39  found an interface eth0 hardware 0x80693c3
Aug/13/2005 17:05:39  create iaid 3929604096 for interface eth0
Aug/13/2005 17:05:39  found an interface eth0 hardware 0xbfaa1f55
Aug/13/2005 17:05:39  found interface eth0 iaid 3929604096
Aug/13/2005 17:05:39 interface eth0 iaid is 3929604096
Aug/13/2005 17:05:39 open_netlink_socket called
Aug/13/2005 17:05:39 netlink_send_rtmsg called


Additional info:

Current CVS version of dhcp6 has still the same problem, so upstream need to be fixed because in IPv6-only networks it makes no sense to assign an IPv6 address to an interface.
Comment 1 Peter Bieringer 2005-08-13 13:07:08 EDT
See also
https://www.redhat.com/archives/fedora-list/2005-April/msg00625.html
Comment 2 Jason Vas Dias 2005-08-15 21:27:26 EDT
This bug is now fixed with dhcpv6-0.10-14_FC4 , available from:
   http://people.redhat.com/~jvdias/dhcpv6/FC4
and which will shortly be released in fc4-updates-testing .

The code was using the obsolete ioctl(sockfd, SIOGIFCONF,...) to get the
hardware addresses for the interfaces in order to construct the iaid in
client6_addr.c's create_iaid() function.

The SIOGIFCONF ioctl only lists devices which have an IPv4 address .

create_iaid() now uses glibc's getifaddrs(...) to list the interfaces,
which does not require them to have an IPv4 address.

Any interface to be configured with dhcp6c MUST however have a LINK LOCAL
IPv6 address, which is automatically assigned by the IPv6 module when the
device is first brought up . 

Please try out the dhcpv6-0.10-14 version and let me know of any issues.

BTW, the configuration with which I tested was:

SERVER /etc/dhcp6s.conf:
interface eth1 {
        renew-time 60;
        rebind-time 90;
        prefer-life-time 130;
        option dns_servers fec0:0:0:1::1 jvd6.;
        allow rapid-commit;
        link eth1
        {
                pool {
                        range fec0:0:0:1::10 to fec0:0:0:1::19/64;
                };
        };
};

SERVER command:
 # dhcp6s -dDf eth1

CLIENT /etc/dhcp6s.conf: ( NONE )

CLIENT command:
 # dhcp6c -dDf eth0

Please append the server and client conf files, the commands used to run them,
and the output of these commands on your client and server systems when 
reporting any dhcpv6 bugs:
 # ip link show
 # ip addr show
Thank You!
Comment 3 Peter Bieringer 2005-09-06 14:30:16 EDT
It's working now, thank you for fixing it - sorry for delay, I was busy.
Comment 4 Peter Bieringer 2005-09-06 14:53:14 EDT
BTW: do you know the reason for the message: netlink_recv_rtgenmsg error

Sep/06/2005 20:40:17 hash add client iaidaddr type 0 for  duid
00:01:00:01:0a:90:bb:f0:00:00:39:ea:77:81 for iaid 3929604096
Sep/06/2005 20:40:17 add an address fec0:0:0:f101::1001 on eth0
Sep/06/2005 20:40:17 open_netlink_socket called
Sep/06/2005 20:40:17 netlink_send_rtmsg called
Sep/06/2005 20:40:17 netlink_recv_rtgenmsg called
Sep/06/2005 20:40:17 netlink_recv_rtgenmsg error
Sep/06/2005 20:40:17 netlink_send_rtgenmsg called
Sep/06/2005 20:40:17 netlink_recv_rtgenmsg called
Sep/06/2005 20:40:17 get_if_flags called
Sep/06/2005 20:40:17 get_if_flags called
Sep/06/2005 20:40:17 netlink_recv_rtgenmsg error

strace shows me that this are triggered after

recvmsg(15, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000},
msg_iov(1)=[{"\24\0\0\0\3\0\2\0\221\345\35C\273\v\0\0\0\0\0\0dhcp6c:
netlink_recv_rtgenmsg called\0:10Yg\1\0n
eth0\0000:01:Ig\1\0001:0a:90:bb:f0:00:00:39:01:23:45 for iaid
3929604096\0\21g\1\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0...
Comment 5 Jason Vas Dias 2005-09-06 15:26:17 EDT
In reply to comment #4:
Yes, I noticed that message, but as yet have not had time to investigate
further, since the routes created seem to be OK .
Are the routes created OK for you ? 
ie. doing an 'ip route show' after dhcp6c configures an interface should
show correct routes for the (IPv6 address)/prefix you configured on the 
server - it does for me.
If the routes are incorrect, or you don't like those messages, please raise
another bug report about them.

Note You need to log in before you can comment on or make changes to this bug.