Bug 165885 - Misnamed package, add Provides?
Misnamed package, add Provides?
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Locale-gettext (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ralf Corsepius
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-13 12:30 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 19:59:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-08-13 12:30:43 EDT
The Perl module package naming convention is perl-$CPANDIST, and this package     
doesn't follow it (should be perl-gettext, not perl-Locale-gettext).     
     
Now, this is very much my fault, didn't catch it in the review, and it doesn't     
really matter much as all dependencies should be specified as     
perl(Locale::gettext) anyway.  I thought it would be nice to add "Provides:     
perl-gettext = %{version}-%{release}" into this package nevertheless.     
     
No strong opinions though; add the provides, or rename the package, or leave 
it as is.  Your call.
Comment 1 Ralf Corsepius 2005-08-14 00:00:52 EDT
(In reply to comment #0)
> The Perl module package naming convention is perl-$CPANDIST, and this package     
> doesn't follow it (should be perl-gettext, not perl-Locale-gettext).     
Is it? Is this documented anywhere?

> Now, this is very much my fault, didn't catch it in the review, and it doesn't
    
> really matter much as all dependencies should be specified as     
> perl(Locale::gettext) anyway.
Exactly. 

But I think the actual problem is in CPAN:

The tarball is called "gettext-*.tar.gz", while the actual module is
"Locale::gettext".

I chose perl-Locale-gettext for the RPM, primarily because I assumed people will
be looking for perl-Locale-gettext-*.rpm when encountering a perl dependency on
Locale::gettext. 

Also, I find calling the RPM perl-gettext*.rpm to be misleading because it would
indicate this module to contain Perl's "one and only gettext binding". However
this is just _one_ aribitrary gettext binding.

>  I thought it would be nice to add "Provides:     
> perl-gettext = %{version}-%{release}" into this package nevertheless.     
I am not opposed to it, if people think this is useful.

> No strong opinions though; add the provides, or rename the package, or leave 
> it as is.  Your call.
Neither strong opinions by me, too.

Advice appreciated
Comment 2 Ville Skyttä 2005-08-14 05:05:23 EDT
I thought that the package naming guidelines would have adviced to use   
perl-$CPANDIST, but instead it goes on to say things about "the CPAN module   
name".   
   
IMO, that makes no sense because the unit of CPAN module packaging is a CPAN   
_distribution_, and the vast majority those distributions contain more than   
one module.  What's "the CPAN module name" then?  Just using the CPAN   
distribution name would work, and is already used in all CPAN packages I'm   
aware of. 
Comment 3 Ralf Corsepius 2005-08-16 03:11:33 EDT
(In reply to comment #2)
> I thought that the package naming guidelines would have adviced to use   
> perl-$CPANDIST, but instead it goes on to say things about "the CPAN module   
> name".   
Can we agree upon this and make this mandatory for FE?

Is there consenus on this?

> IMO, that makes no sense because the unit of CPAN module packaging is a CPAN   
> _distribution_, and the vast majority those distributions contain more than   
> one module.  What's "the CPAN module name" then?  Just using the CPAN   
> distribution name would work, and is already used in all CPAN packages I'm   
> aware of.
I would not bet on FC, but I guess, you are right as far as FE is concerned.

How to proceed with this package?
1. Apply cvs tricks (I.e. an admin moving the files in CVS)?
2. Re-import the package into CVS under "perl-gettext" and "cvs rm"
perl-Locale-gettext?
3. Let it be in FC-4 and re-import it as "perl-gettext" into "devel"?
Comment 4 Marius Feraru 2005-08-18 13:38:41 EDT
> IMO, that makes no sense because the unit of CPAN module packaging is a CPAN   
> _distribution_, and the vast majority those distributions contain more than   
> one module.  What's "the CPAN module name" then?

Usually, each cpan distribution has a so called "main module", hence the
VERSION_FROM MakeMaker option.

So, IMHO, maybe Ralf's choice was not so bad after all, or at least I think he
has a point. ;-)
Comment 5 Ville Skyttä 2005-08-18 14:05:35 EDT
Sure, it wasn't entirely unexpected, otherwise I would have noticed it in my  
review :) 
  
But I still think using the CPAN distribution name is the right thing to do, 
at least wrt the guidelines.  Why settle for "usually they have a main 
module", and spend time pondering what might The Module be (checking 
VERSION_FROM is not necessarily a very good criteria for that), when all of 
them have an unambiguous distribution name as long as the unit of packaging is 
the very distribution? 
 
Anyway, as said, IMO it's Ralf's call whether he wants to do something about 
this package, and my .02€ is listed in the summary and initial comment of this 
bug... 
Comment 6 Ralf Corsepius 2005-08-18 23:03:28 EDT
(In reply to comment #5)
> Sure, it wasn't entirely unexpected, otherwise I would have noticed it in my  

> Anyway, as said, IMO it's Ralf's call whether he wants to do something about 
> this package, and my .02€ is listed in the summary and initial comment of this 
> bug... 

... and I had asked for opinions in comment #3 ;)

Tell me how you want me to proceed with it. 

To me, the current naming of this package is fine, but I also don't have a
problem in changing it, if there is common agreement on this matter.

Technically, adding a "provides: perl-gettext" is matter of minutes, but
renaming the package would require more "brains".
Comment 7 Ville Skyttä 2005-08-19 11:40:01 EDT
As said, your call.  If I was the maintainer of this package, I would add 
"Provides: perl-gettext = %{version}-%{release}" and leave it at that. 
Comment 8 Ralf Corsepius 2005-08-19 19:59:24 EDT
Added 
"Provides: perl-gettext = %{version}-%{release}"

Note You need to log in before you can comment on or make changes to this bug.