Bug 165902 - fence_ilo does not work with ilo 1.64 (11/11/2004)
fence_ilo does not work with ilo 1.64 (11/11/2004)
Status: CLOSED DUPLICATE of bug 161352
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam "mantis" Manthei
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-13 16:36 EDT by Axel Thimm
Modified: 2009-04-16 15:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 17:55:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log output from fence_ilo -v (3.09 KB, text/plain)
2005-08-13 16:36 EDT, Axel Thimm
no flags Details

  None (edit)
Description Axel Thimm 2005-08-13 16:36:11 EDT
Description of problem:
fence_ilo on an iLO interface with firmware 1.64 (11/11/2004) returns w/o
changing power status.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.fence_ilo -a <ilo-ip> -l <login> -p <password>
2.
3.
  
Actual results:
no power status change

Expected results:
should powercycle the system

Additional info:
The iLO interface returns:
<INFORM>Scripting utility should be updated to the latest version.</INFORM>
Comment 1 Axel Thimm 2005-08-13 16:36:11 EDT
Created attachment 117712 [details]
log output from fence_ilo -v
Comment 2 Adam "mantis" Manthei 2005-08-15 10:40:39 EDT
What version of fence_ilo are you using?  What architecture is the machine?  

There were some issues with ilo on acpid enabled machines, ia64 machines and
those with later versions of the firmware (1.70 and later).  These issues have
since been addressed in the RHEL3u6 and RHEL4u2 releases of GFS.  See bug #161352
Comment 3 Axel Thimm 2005-08-15 13:55:41 EDT
$FENCE_RELEASE_NAME="1.32.1", the system is a dual-xeon em64t, and the firmware
is 1.64 (e.g. below 1.70).

I'm not authorized to view bug #161352, could you summarize? I also don't have
access to prereleases/betas of RHEL4U2.
Comment 4 Adam "mantis" Manthei 2005-08-15 15:48:47 EDT
It's possible that em64t is having some of the same issues that ia64 was having.
 The basic gist is that the acpid was causing the nodes to interpret the power
off command as a gracefull poweroff and was causing poor interaction between the
ilo and GFS.  The issue was resolved with this check-in:
http://sources.redhat.com/cgi-bin/cvsweb.cgi/cluster/fence/agents/ilo/fence_ilo.pl?rev=1.3.8.1&content-type=text/x-cvsweb-markup&cvsroot=cluster

Let me know if this version of fence_ilo fixes the problem for you.
Comment 5 Axel Thimm 2005-08-15 17:12:46 EDT
The CVS version seems to work fine, thank you!

Any chance this will make it soon into rhn updates?
Comment 6 Adam "mantis" Manthei 2005-08-15 17:55:15 EDT
Since the CVS version works for you, I'm going to resolve this a duplicate of
bug #161352

The fix should be included in the next update to rhn.  It's in GFS-6.0.2.25-0
for RHEL3 and fence-1.32.6-0 for RHEL4.

*** This bug has been marked as a duplicate of 161352 ***

Note You need to log in before you can comment on or make changes to this bug.