Bug 1659273 - [HPE 8.0 Bug] /etc/kdump.conf extra_modules not being built into kdump initrd.
Summary: [HPE 8.0 Bug] /etc/kdump.conf extra_modules not being built into kdump initrd.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: kexec-tools
Version: 8.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 8.0
Assignee: kdump-bugs
QA Contact: Kernel General QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-13 23:52 UTC by Jerry Hoemann
Modified: 2018-12-17 01:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-17 01:39:25 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
/etc/kdump.conf (7.11 KB, text/plain)
2018-12-13 23:52 UTC, Jerry Hoemann
no flags Details
lsinitrd output of autogenerated kdump init rd. (14.10 KB, text/plain)
2018-12-14 00:05 UTC, Jerry Hoemann
no flags Details
lsinitrd output of manually created kdump init rd. (49.23 KB, text/plain)
2018-12-14 00:08 UTC, Jerry Hoemann
no flags Details

Description Jerry Hoemann 2018-12-13 23:52:05 UTC
Created attachment 1514267 [details]
/etc/kdump.conf

Description of problem:

On DL560 Gen 9.  When adding "extra_modules hpwdt" to file /etc/kdump.conf and rebuilding the kdump initrd, I don't see the hpwdt module included in the dump initrd.


Version-Release number of selected component (if applicable):

Rhel 8.0 Snapshot 1.

How reproducible:

100%

Steps to Reproduce:
1.  To /etc/kdump.conf add line:  extra_modules hpwdt
2.  Remove /boot/initramfs-4.18.0-40.el8.x86_64kdump.img
3.  systemctl restart kdump
4.  lsinitrd /boot/initramfs-4.18.0-40.el8.x86_64kdump.img

Actual results:

The output of lsinitrd would show that dracut was run with argument --add-drivers to add the hpwdt driver, but the listing of modules does not show hpwdt.

E.g.:

Arguments: --quiet --hostonly --hostonly-cmdline --hostonly-i18n --hostonly-mode 'strict' -o 'plymouth dash resume ifcfg' --mount '/dev/disk/by-uuid/25ef10d5-10c6-423f-8025-afa5f74014ad /sysroot xfs defaults' --add-drivers ' hpwdt' --no-hostonly-default-device -f


Expected results:

hpwdt should be listed as a module.

Additional info:

If I manually run dracut using the above arguments like so:
dracut --quiet --hostonly --hostonly-cmdline --hostonly-i18n --hostonly-mode strict -o plymouth dash resume ifcfg --mount /dev/disk/by-uuid/25ef10d5-10c6-423f-8025-afa5f74014ad /sysroot xfs defaults --add-drivers  hpwdt --no-hostonly-default-device -f /boot/initramfs-4.18.0-40.el8.x86_64kdump.img

Then hpwdt will be listed in the modules of the dump initrd file.

Comment 1 Jerry Hoemann 2018-12-14 00:05:00 UTC
Created attachment 1514271 [details]
lsinitrd output of autogenerated kdump init rd.

This is the output of lsinitrd on the /boot/initramfs-4.18.0-40.el8.x86_64kdump.img automatically generated after

1. editing kdump.conf
2. Running: systemctl restart kdump

Comment 2 Jerry Hoemann 2018-12-14 00:08:59 UTC
Created attachment 1514273 [details]
lsinitrd output of manually created kdump init rd.

When I ran dracut myself with:


dracut --quiet --hostonly --hostonly-cmdline --hostonly-i18n --hostonly-mode strict -o plymouth dash resume ifcfg --mount /dev/disk/by-uuid/25ef10d5-10c6-423f-8025-afa5f74014ad /sysroot xfs defaults --add-drivers  hpwdt --no-hostonly-default-device -f /boot/initramfs-4.18.0-40.el8.x86_64kdump.img

I would get hpwdt listed in the module.

Comment 3 Baoquan He 2018-12-14 00:56:36 UTC
Hi Jerry,

Hmm, we have below line in kdump.conf, so is " dracut_args --add-drivers " OK to you to set it in kdump.conf?

#dracut_args --omit-drivers "cfg80211 snd" --add-drivers "ext2 ext3"

Thanks
Baoquan

Comment 4 Kairui Song 2018-12-14 02:06:32 UTC
Hi Jerry,

In latest dracut version there is a "squash" dracut module, that will squash many files in the initramfs into a squashfs image to save memory usage.
Kdump will now enable the module since the resource reserved for the second kernel is limited, so we want to save memory.
The side effect is that some files are no visible by lsinitrd, but they do exits after the second kernel is started.
I see your initramfs image does have a squash/root.img, could you try to unsquash that with "unsquashfs"? I think you will find the module you want there.

Comment 5 Jerry Hoemann 2018-12-14 20:40:30 UTC
(In reply to Kairui Song from comment #4)
> Hi Jerry,
> 
> In latest dracut version there is a "squash" dracut module, that will squash
> many files in the initramfs into a squashfs image to save memory usage.
> Kdump will now enable the module since the resource reserved for the second
> kernel is limited, so we want to save memory.
> The side effect is that some files are no visible by lsinitrd, but they do
> exits after the second kernel is started.
> I see your initramfs image does have a squash/root.img, could you try to
> unsquash that with "unsquashfs"? I think you will find the module you want
> there.

You are correct.  The hpwdt module was added to the root.img squashfs.  hpwdt does get loaded in the capture kernel environment.

Thanks

Comment 6 Dave Young 2018-12-17 01:39:25 UTC
Hi Jerry

Thanks for testing, I will close this bug then.

Thanks
Dave


Note You need to log in before you can comment on or make changes to this bug.