Bug 165933 - Query fail on Collabnet Bugzilla repositories
Query fail on Collabnet Bugzilla repositories
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: eclipse-bugzilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-14 18:08 EDT by Eugene Kuleshov
Modified: 2012-02-17 16:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-16 11:14:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kuleshov 2005-08-14 18:08:20 EDT
Description of problem:

Query doesn't work on  Bugzilla repositories on all Collabnet sites. E.g.
http://subclipse.tigris.org/issues/

On retrieveing data getting an internal error:

java.lang.NullPointerException
at
org.eclipse.team.bugzilla.operations.CachedOperations.getQueryData(CachedOperations.java:58)
at org.eclipse.team.bugzilla.datatypes.DataCache.refreshQuery(DataCache.java:191)
at org.eclipse.team.bugzilla.model.BugzillaQuery.refresh(BugzillaQuery.java:80)
at
org.eclipse.team.bugzilla.operations.RefreshOperation.fetch(RefreshOperation.java:159)
at
org.eclipse.team.bugzilla.operations.RefreshOperation.fetchElement(RefreshOperation.java:137)
at
org.eclipse.team.bugzilla.operations.RefreshOperation.run(RefreshOperation.java:122)
at
org.eclipse.team.internal.ui.actions.JobRunnableContext.run(JobRunnableContext.java:146)
at
org.eclipse.team.internal.ui.actions.JobRunnableContext$ResourceJob.runInWorkspace(JobRunnableContext.java:72)
at
org.eclipse.core.internal.resources.InternalWorkspaceJob.run(InternalWorkspaceJob.java:38)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)

Version-Release number of selected component (if applicable):
Bugzilla Eclipse plugin version 0.1.1

How reproducible:

Always fail

Steps to Reproduce:
1. Add repository. E.g. http://subclipse.tigris.org/issues/
2. Add new query with default settings. Actually this is probably what cause
problem, because there is no products defined in these repositories. Like one
product per repository - URL based. 
3. Wait for end of the refresh
  
Actual results:

See exception above

Expected results:

Query should successfully retrieve data from the repository.

Additional info:

Please help Mylar project :-)
Comment 1 Jeff Pound 2005-08-16 11:14:31 EDT
I havn't had a chance to closely examin that bugzilla installation, but it
appears that it has deviated too far from stock bugzilla to work with
eclipse-bugzilla at the moment. If bugzilla ever gets an XMLRPC or WebService
this won't be an issuse (see
https://bugzilla.mozilla.org/show_bug.cgi?id=224577). Until then its not
possible to support every modified version of bugzilla. When i have a chance Ill
try and have a look at what subclipse has changed in their bugzilla install and
see if its possible to modify the parsers to support it.

Because I can't assure support for every custom bugzilla modification I'm
marking this as WONTFIX.


>>Please help Mylar project :-)

see mylar-dev@eclipse.org list for this discussion. Mylars java 1.5 dependancy
currently precludes the use of free java implimentations (such as gcj which is
shipped with fedora).
Comment 2 Eugene Kuleshov 2005-08-16 12:37:42 EDT
Please note that it is not just Subclipse. There are hundreds of projects that
are hosted on CollabNet-based sites including collabnet, tigris.org, java.net
and dev2dev.bea.com  I do believe all those sites are using the same
modification of Bugzilla. So, please consider this fix.

Please leave your comments about Java 5 in issue 104601 that is exploring making
Mylar run on JDK 1.4. "https://bugs.eclipse.org/bugs//show_bug.cgi?id=104601

Note You need to log in before you can comment on or make changes to this bug.