Bug 165969 - OOo 1.9.123-1.2.0.fc5 crashes on open file
OOo 1.9.123-1.2.0.fc5 crashes on open file
Status: CLOSED DUPLICATE of bug 165712
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Depends On:
  Show dependency treegraph
Reported: 2005-08-15 08:59 EDT by Maxim Britov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-08-15 13:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Maxim Britov 2005-08-15 08:59:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050814 Firefox/1.0+

Description of problem:
Start calc, press open file and gets crash :(

(soffice.bin:25384): Gtk-CRITICAL **: gtk_file_system_path_is_local: assertion `path != NULL' failed
---start copy and paste here---
0x432bcb8a: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1db8a
0x432bd3d8: /usr/lib/openoffice.org2.0/program/libuno_sal.so.3 + 0x1e3d8
0xffffe420:  + 0x420 (__kernel_sigreturn + 0x0)
0x45a09550: /usr/lib/libgtk-x11-2.0.so.0 + 0xd5550
0x459f79ef: /usr/lib/libgtk-x11-2.0.so.0 + 0xc39ef
0x45a0da06: /usr/lib/libgtk-x11-2.0.so.0 + 0xd9a06
0x459f79ef: /usr/lib/libgtk-x11-2.0.so.0 + 0xc39ef
0x45a0da06: /usr/lib/libgtk-x11-2.0.so.0 + 0xd9a06
0x459f79ef: /usr/lib/libgtk-x11-2.0.so.0 + 0xc39ef
0x459f7ff3: /usr/lib/libgtk-x11-2.0.so.0 + 0xc3ff3 (gtk_file_chooser_set_current_folder_uri + 0x7a)
0xa88ecdfd: /usr/lib/openoffice.org2.0/program/fps_gnome.uno.so + 0x7dfd
0xa88ed96b: /usr/lib/openoffice.org2.0/program/fps_gnome.uno.so + 0x896b
0xac7c22e9: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c62e9
0xac7c335a: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c735a
0xac7c5a97: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c9a97
0xac7c5af5: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c9af5
0xac7c5edf: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1c9edf
0xac7c6663: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1ca663 (sfx2::FileDialogHelper::Execute(String const&, SvStringsDtor*&, SfxItemSet*&, String&) + 0x2f)
0xac7c810a: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1cc10a
0xac694ef7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x98ef7
0xac69bdd0: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x9fdd0
0xac7929da: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1969da
0xac791dc7: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x195dc7
0xac7920db: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1960db
0xac79217e: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x19617e
0xac693312: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x97312
0xac7ab0dd: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1af0dd
0xac7aaf98: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aef98
0xac7ab0f2: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1af0f2
0xac7aaf84: /usr/lib/openoffice.org2.0/program/libsfx680li.so + 0x1aef84
0x43941a42: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x82a42
0x43a967fb: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x1d77fb
0xb7c89e72: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x1ee72
0xb7caf0cd: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x440cd (SalDisplay::DispatchInternalEvent() + 0xad)
0xb7ceaa73: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xaa73
0x455682ee: /usr/lib/libglib-2.0.so.0 + 0x272ee
0x4556607e: /usr/lib/libglib-2.0.so.0 + 0x2507e (g_main_context_dispatch + 0x1dc)
0x45569096: /usr/lib/libglib-2.0.so.0 + 0x28096
0x45569578: /usr/lib/libglib-2.0.so.0 + 0x28578 (g_main_context_iteration + 0x66)
0xb7cea699: /usr/lib/openoffice.org2.0/program/libvclplug_gtk680li.so + 0xa699
0xb7cb0d99: /usr/lib/openoffice.org2.0/program/libvclplug_gen680li.so + 0x45d99 (X11SalInstance::Yield(unsigned char) + 0x29)
0x43947da4: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88da4 (Application::Yield() + 0x50)
0x43947de2: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x88de2 (Application::Execute() + 0x26)
0x80656ac: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1d6ac (desktop::Desktop::Main() + 0x149a)
0x4394d1d1: /usr/lib/openoffice.org2.0/program/libvcl680li.so + 0x8e1d1 (SVMain() + 0x45)
0x806075f: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x1875f (sal_main + 0x47)
0x452c549f: /lib/libc.so.6 + 0x1549f (__libc_start_main + 0xdf)
0x8060695: /usr/lib/openoffice.org2.0/program/soffice.bin + 0x18695 (Window::RequestHelp(HelpEvent const&) + 0x31)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.start OOo calc/writer
2.press open file

Actual Results:  crash

Additional info:
Comment 1 Maxim Britov 2005-08-15 09:08:18 EDT
Works fine with: options - general - use openoffice dialogs
Comment 2 Caolan McNamara 2005-08-15 09:25:59 EDT
This doesn't happen for me, so there must be something slightly different going
on. If you use the openoffice.org dialogs, what is the path they open in ?, once
the openoffice.org dialog has been used and you revert to the gtk dialog does it
still crash ? Anything unusual about your setup. KDE or GNOME ?
Comment 3 Caolan McNamara 2005-08-15 09:43:29 EDT
or maybe, what's the output of
> locale
Comment 4 Maxim Britov 2005-08-15 12:38:33 EDT
Default path is /home/user/docums/
Always crash. I can select OOo dialogs and change default path, then disable OOo
dialigs and fet crash on selection default path, for example.
I use Gnome and Fedora rawhide.
$ locate said:


$ LC_ALL=en_US.UTF-8 /usr/lib/openoffice.org2.0/program/scalc
(soffice.bin:29085): .......
Comment 5 Maxim Britov 2005-08-15 12:40:42 EDT
Generic OOo also crash
$ /opt/openoffice.org1.9.109/program/scalc

(soffice.bin:29291): Gtk-CRITICAL **: gtk_file_system_path_is_local: assertion
`path != NULL' failed/opt/openoffice.org1.9.109/program/soffice: line 245: 29291
Segfault  "$sd_prog/$sd_binary" "$@"
Comment 6 Caolan McNamara 2005-08-15 13:17:15 EDT

*** This bug has been marked as a duplicate of 165712 ***

Note You need to log in before you can comment on or make changes to this bug.