Bug 1659711 - amdgpu (carrizo) Kernel 4.19.10-300.fc29.x86_64 Causes xfce desktop environment to become unresponsive
Summary: amdgpu (carrizo) Kernel 4.19.10-300.fc29.x86_64 Causes xfce desktop environme...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-15 15:47 UTC by chiguy1256
Modified: 2019-01-24 12:37 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-24 12:37:42 UTC


Attachments (Terms of Use)
Copy of messages from /var/log (2.56 MB, text/plain)
2018-12-15 15:47 UTC, chiguy1256
no flags Details
lnxi output (2.78 KB, text/plain)
2018-12-15 16:02 UTC, chiguy1256
no flags Details
journal messages (96.72 KB, text/plain)
2018-12-15 16:03 UTC, chiguy1256
no flags Details
blame_before.txt (3.35 KB, text/plain)
2018-12-19 21:35 UTC, chiguy1256
no flags Details
blame_after.txt (3.26 KB, text/plain)
2018-12-19 21:35 UTC, chiguy1256
no flags Details
Chrome open (4.61 MB, image/jpeg)
2018-12-20 13:20 UTC, chiguy1256
no flags Details
opening Chrome (168.23 KB, image/jpeg)
2018-12-20 13:21 UTC, chiguy1256
no flags Details
Chrome being displayed after switching back from tty3 (235.20 KB, image/jpeg)
2018-12-20 13:22 UTC, chiguy1256
no flags Details
trying to use application menu (250.72 KB, image/jpeg)
2018-12-20 13:22 UTC, chiguy1256
no flags Details
message file from the last two reboots (676.79 KB, text/plain)
2018-12-21 16:39 UTC, Phil
no flags Details
Screenshot when LXDE broken (2.61 MB, image/jpeg)
2018-12-23 03:59 UTC, Phil
no flags Details

Description chiguy1256 2018-12-15 15:47:49 UTC
Created attachment 1514616 [details]
Copy of messages from /var/log

Description of problem:
Kernel 4.19.8-300.fc29.x86_64 Causes xfce desktop environment to become unresponsive.  After upgrading to the 4.19.8-300 kernel, I could log onto my xfce desktop.  However, upon doing so it prettty becomes unresponsive.  I have to switch to tty3 or 4 and log in as root.  Then reboot the system, but choose kernel 4.18.16-300 instead.  I have since removed 4.19.8-300 because of this issue.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Kernel upgrade to 4.19.8-300.
2.
3.

Actual results:  Upgrade causes xfce desktop environment to become unresponsive.


Expected results:  I would expect no issues after a kernel upgrade.


Additional info:

Comment 1 chiguy1256 2018-12-15 16:02:43 UTC
Created attachment 1514617 [details]
lnxi output

Comment 2 chiguy1256 2018-12-15 16:03:46 UTC
Created attachment 1514618 [details]
journal messages

Comment 3 chiguy1256 2018-12-19 13:18:18 UTC
I just tried the kernel upgrade to 4.19.9-300 and I experienced the same issue.  I removed this kernel.  The kernel that I currently have installed on my system is 4.18.16 and it runs fine.

Comment 4 Steve 2018-12-19 19:31:34 UTC
(In reply to chiguy1256 from comment #0)
...
> Kernel 4.19.8-300.fc29.x86_64 Causes xfce desktop environment to become
> unresponsive.  After upgrading to the 4.19.8-300 kernel, I could log onto my
> xfce desktop.  However, upon doing so it prettty becomes unresponsive.  I
> have to switch to tty3 or 4 and log in as root.
...

Could you be more specific about what you mean by "unresponsive"?

1. How quickly does the pointer move when you use the touchpad?
2. How long does it take to go from entering your password on the login screen to displaying the desktop?
3. When you click on the "Applications" menu, how long does it take for the menu to be displayed?
4. How long does it take to open a terminal window?
5. When you type in a terminal window, how long does it take for the text to be displayed?

Comment 5 chiguy1256 2018-12-19 21:05:28 UTC
I install again and try to provide accurate times for you.  Thanks.

Comment 6 chiguy1256 2018-12-19 21:35:10 UTC
Created attachment 1515755 [details]
blame_before.txt

Comment 7 chiguy1256 2018-12-19 21:35:41 UTC
Created attachment 1515756 [details]
blame_after.txt

Comment 8 chiguy1256 2018-12-19 21:44:45 UTC
I have added two attachments.  blame_before.txt is prior to the kernel upgrade and blame_after.txt is after the kernel upgrade.

1. How quickly does the pointer move when you use the touchpad?
I don't usually use the touchpad.  However, my mouse pointer moved normally.

2. How long does it take to go from entering your password on the login screen to displaying the desktop?
It was difficult to get a timing on this.  It took a little longer than prior to the kernel upgrade, but not much.

3. When you click on the "Applications" menu, how long does it take for the menu to be displayed?
When I would try to go the Applications menu, the menu wouldn't fully display.  I would get a partial image.

4. How long does it take to open a terminal window?  
Normally a terminal window opens almost immediately.  After the kernel upgrade, the terminal window seemed to a while to open.

5. When you type in a terminal window, how long does it take for the text to be displayed? 
When I tried to type, the text did not display.  Maybe I got too impatient.  I switch to tty3 and rebooted back to the previous kernel and removed the kernel upgrade.

I hope the two documents I provided give you a better idea on the timings.  Do you have any suggestions on how I can better provide the timings you requested?

Thanks.

Comment 9 Steve 2018-12-20 04:28:41 UTC
Thanks for your detailed report. I see now from your log file that you do indeed have a USB mouse attached.

When you switched to tty3, was text displayed as quickly as you expected when you typed?

Did you try switching back to the graphical display? If so, what did it show?

BTW, it is possible to configure grub2 so that you can have a non-working kernel installed, yet have a working kernel boot by default. That would make it easier to run additional tests.

You can set it up using this graphical tool:

# dnf install grub-customizer

After installation, "Grub Customizer" should be listed in a desktop menu.

Click "General settings" and select a kernel from the "predefined" menu. Click "Save".

It is also possible to change the order in which kernels are listed in the grub2 menu.

NB: "Grub Customizer" runs as root and modifies these files:

/etc/default/grub
/boot/grub2/grub.cfg

Comment 10 chiguy1256 2018-12-20 12:27:32 UTC
When you switched to tty3, was text displayed as quickly as you expected when you typed?
Fromm tty3 or 4, the text displayed immediately as I typed.

Did you try switching back to the graphical display? If so, what did it show?  
On one of my earlier attempts I did try to switch back to the GUI and it displayed, but any action I attempted resulted in "misbehavior".

I will reinstall the latest kernel and change the order of the kernels listed in grub2 as you suggested.

Thank you so much.

Comment 11 chiguy1256 2018-12-20 13:20:36 UTC
Created attachment 1515848 [details]
Chrome open

Comment 12 chiguy1256 2018-12-20 13:21:15 UTC
Created attachment 1515849 [details]
opening Chrome

Comment 13 chiguy1256 2018-12-20 13:22:11 UTC
Created attachment 1515850 [details]
Chrome being displayed after switching back from tty3

Comment 14 chiguy1256 2018-12-20 13:22:43 UTC
Created attachment 1515852 [details]
trying to use application menu

Comment 15 chiguy1256 2018-12-20 13:26:03 UTC
I've just added 4 jpg files.  I took these pictures from my cell phone and email them to myself.  I was unable to use Screenshooter due to the desktop issues when running with the latest kernel.  

When I would try to open an application and then switch to tty3 and then switch back to the gui, the window would display.

I hope this helps.  Please let me know if you need additional information.  Thanks.

Comment 16 Phil 2018-12-20 17:15:56 UTC
I want to note that I have encountered this bug also. It breaks LXDE, LXQt, and XFCE. I think it also breaks MATE.

Each of these desktops are totally unusable. After downgrading to kernel 4-18 I am now able to use LXDE again. If you need I can explain how LXDE is also broken.

Comment 17 Steve 2018-12-20 17:36:18 UTC
(In reply to chiguy1256 from comment #15)
...

Thanks for attaching the screenshots and for the additional info.

kernel-4.19.9-300.fc29.x86_64 has been released, so could you run a full update:

# dnf update --refresh

NB: The kernel update will change your grub2 menu.


Also, a new linux-firmware package will be available soon. When it is, this should update it:

# dnf update linux-firmware --enablerepo=updates-testing

See: https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba224c644f

If you don't want to wait:

# dnf update https://kojipkgs.fedoraproject.org//packages/linux-firmware/20181219/89.git0f22c852.fc29/noarch/linux-firmware-20181219-89.git0f22c852.fc29.noarch.rpm


For the record, your log shows:

Dec 15 09:31:57 fedora kernel: [drm:construct [amdgpu]] *ERROR* construct: Invalid Connector ObjectID from Adapter Service for connector index:2! type 0 expected 3

Comment 18 Steve 2018-12-20 18:20:35 UTC
(In reply to Phil from comment #16)
> I want to note that I have encountered this bug also. It breaks LXDE, LXQt,
> and XFCE. I think it also breaks MATE.
> 
> Each of these desktops are totally unusable. After downgrading to kernel
> 4-18 I am now able to use LXDE again. If you need I can explain how LXDE is
> also broken.

Thanks for your report and for confirming that the problem occurs with several desktops.

Could you attach a log file for when you booted from the 4.19 kernel? If you haven't rebooted again, this should find the log:

$ journalctl -b -1 --no-hostname > journalctl-phil-1.log # The "-1" option selects the log for the previous boot.

Attach journalctl-phil-1.log to this bug report.

If you have rebooted more than once, search for the 4.19 log:

$ journalctl -b -1 -g vmlinuz --no-pager
$ journalctl -b -2 -g vmlinuz --no-pager
...

Comment 19 chiguy1256 2018-12-20 20:48:03 UTC
The issue persists in 4.19.9 as well.

Comment 20 chiguy1256 2018-12-21 01:18:01 UTC
Steve,

What can I do about the "[drm:construct [amdgpu]] *ERROR* construct: Invalid Connector ObjectID from Adapter Service for connector index:2! type 0 expected 3" message that you brought to my attention?

Thanks.

Comment 21 Steve 2018-12-21 04:02:46 UTC
(In reply to chiguy1256 from comment #19)
> The issue persists in 4.19.9 as well.

Thanks for your report. According to your log*, you are using the amdgpu driver. There are a number of bugs related to it, although the symptoms are different (boot hang).**

Anyway, could you try updating the linux-firmware package?

# dnf update https://kojipkgs.fedoraproject.org//packages/linux-firmware/20181219/89.git0f22c852.fc29/noarch/linux-firmware-20181219-89.git0f22c852.fc29.noarch.rpm

According to a comment on Bodhi***, the initramfs needs to be rebuilt after the linux-firmware update:

# dracut --kver 4.19.9-300.fc29.x86_64 --force

Documentation:

$ man dracut

NB: You can do all of the above when booted from a working kernel.


* Snippet from your log:
Dec 15 09:31:57 fedora kernel: [drm] amdgpu kernel modesetting enabled.
...
Dec 15 09:31:57 fedora kernel: fb: switching to amdgpudrmfb from EFI VGA
Dec 15 09:31:57 fedora kernel: [drm] initializing kernel modesetting (CARRIZO 0x1002:0x9874 0x103C:0x80AF 0xC5).

** Bug 1659810 - linux-firmware: amdgpu fatal error during gpu init 

*** bugfix update in Fedora 29 for linux-firmware
https://bodhi.fedoraproject.org/updates/FEDORA-2018-ba224c644f

Comment 22 Phil 2018-12-21 16:39:09 UTC
Created attachment 1516166 [details]
message file from the last two reboots

First reboot with kernet 4.19.9 - LXDE was broken, second reboot with 4.18.16 kernel and LXDE works.

Comment 23 Phil 2018-12-21 16:42:47 UTC
Regarding the above attachment. I have a Dell laptop with AMD A12-9700P RADEON R7, 10 COMPUTE CORES 4C+6G. I do not see the amdgpu error that was mentioned, but LXDE is broken (as well as LXqt and XFCE) with the 4.19 .9 kernel..

Comment 24 Steve 2018-12-21 19:14:33 UTC
(In reply to Phil from comment #23)
> Regarding the above attachment. I have a Dell laptop with AMD A12-9700P
> RADEON R7, 10 COMPUTE CORES 4C+6G. I do not see the amdgpu error that was
> mentioned, but LXDE is broken (as well as LXqt and XFCE) with the 4.19 .9
> kernel..

Thanks for testing and attaching your log. You appear to have the same AMD graphics processor as chiguy (AMD CARRIZO):

Dec 21 10:09:49 mylaptop kernel: [drm] amdgpu kernel modesetting enabled.
...
Dec 21 10:09:49 mylaptop kernel: [drm] initializing kernel modesetting (CARRIZO 0x1002:0x9874 0x1028:0x0769 0xC9).

The carrizo firmware in the linux-firmware package has changed between the -88 and the -89 versions*, so I would suggest updating linux-firmware and rebuilding the initramfs:

# dnf update https://kojipkgs.fedoraproject.org//packages/linux-firmware/20181219/89.git0f22c852.fc29/noarch/linux-firmware-20181219-89.git0f22c852.fc29.noarch.rpm

# dracut --kver 4.19.9-300.fc29.x86_64 --force

* amdgpu: update carrizo firmware to 18.40
https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/commit/?id=7ceb224ac773eff6976b100244d873a74fdf2b6d

Comment 25 Phil 2018-12-21 23:13:08 UTC
I updated the firmware and rebuilt the initramfs. The 4.19.9 kernel still has the same problem with LXDE. The kernel 4.18.16 runs LXDE OK.

Comment 26 Phil 2018-12-21 23:25:20 UTC
The kernel 4.19.10-300 also has the same problem.

Comment 27 Steve 2018-12-22 04:30:03 UTC
(In reply to chiguy1256 from comment #20)
...
> What can I do about the "[drm:construct [amdgpu]] *ERROR* construct: Invalid
> Connector ObjectID from Adapter Service for connector index:2! type 0
> expected 3" message that you brought to my attention?
...

Try updating linux-firmware and then the kernel:

# dnf update linux-firmware --enablerepo=updates-testing  # 20181219-89.git0f22c852.fc29

# dnf update kernel --enablerepo=updates-testing  # 4.19.10-300.fc29


For the record, that error message is identical to the one in this bug filed against xorg-x11-drv-amdgpu:

Bug 1658845 - AMDGPU: Invalid Connector ObjectID from Adapter Service for connector index

Comment 28 Steve 2018-12-22 04:57:55 UTC
(In reply to Phil from comment #25)
> I updated the firmware and rebuilt the initramfs. The 4.19.9 kernel still
> has the same problem with LXDE. The kernel 4.18.16 runs LXDE OK.

(In reply to Phil from comment #26)
> The kernel 4.19.10-300 also has the same problem.

Thanks for testing. In Comment 16 you offered to "explain how LXDE is also broken." Could you do that?

If there are any graphics anomalies, could you attach a photo?

Comment 29 chiguy1256 2018-12-22 22:25:33 UTC
I updated the firmware as you suggested.  Still have the issue with 4.19.9.  Do I need to rebuild the initramfs as well?

Comment 30 Steve 2018-12-22 23:32:32 UTC
(In reply to chiguy1256 from comment #29)
> I updated the firmware as you suggested.  Still have the issue with 4.19.9. 
> Do I need to rebuild the initramfs as well?

Yes:

# dracut --kver 4.19.9-300.fc29.x86_64 --force

Normally that is done automatically when you update the kernel, so you won't need to run dracut if you update to 4.19.10-300.fc29:

# dnf update kernel # 4.19.10-300.fc29 is in the "updates" repo


NB: With the default Fedora configuration, only three kernels are retained, so if you do a kernel update you could end up with no working kernels. The solution is to make this change to /etc/dnf/dnf.conf:

#installonly_limit=3
installonly_limit=0 # <<<<< stop dnf from removing kernels

Documentation:

$ man dnf.conf

Comment 31 chiguy1256 2018-12-23 00:05:07 UTC
I just tried the kernel upgrade to 4.19.10 and it has the same problem.

Comment 32 Steve 2018-12-23 00:26:28 UTC
(In reply to chiguy1256 from comment #31)
> I just tried the kernel upgrade to 4.19.10 and it has the same problem.

Thanks for confirming that. This is about as far as we can go.

However, I would suggest adding this to the beginning of the bug summary, so it is clear where the problem seems to be:

"amdgpu (carrizo): ..." (click "edit" next to the bug summary at the top of the page)

You can check for kernel updates on this page (or by running "dnf update kernel"):

https://bodhi.fedoraproject.org/updates/?search=kernel

Comment 33 chiguy1256 2018-12-23 00:46:17 UTC
After performing the firmware update, I noticed that I still see the amdgpu error message in the journalctl.

Comment 34 Steve 2018-12-23 02:34:49 UTC
(In reply to chiguy1256 from comment #33)
> After performing the firmware update, I noticed that I still see the amdgpu
> error message in the journalctl.

Thanks for mentioning that. Was that with kernel 4.19.10? And thanks for updating the bug summary.

Phil: Do you see that error messages with kernel 4.19.10?

For the record, the error message is in Attachment 1514618 [details] above:

Dec 15 09:31:57 fedora kernel: [drm:construct [amdgpu]] *ERROR* construct: Invalid Connector ObjectID from Adapter Service for connector index:2! type 0 expected 3

Comment 35 Phil 2018-12-23 03:59:18 UTC
Created attachment 1516290 [details]
Screenshot when LXDE broken

I never have see any amdgpu error messages in the log files. With either the 4.19.9 or the 4.19.10 kernels.

The problem that I have with LXDE occurs after I log in. I can successfully open lxterminal and run commands. I open it by clicking on the terminal icon in the bottom toolbar.  However if I open PCManFM by clicking on the PCManFM icon in the tool bar, it opens but only shows the top of the windon and a very fine line around what the open window should be. Nothing else happens, even if I wait a long time. If I was running top in the terminal the output stops updating. If I then click on the open terminal the PCManFM window finishes opening. I can type a command in the terminl, nothing happens, it doesn't even show the text that I typed. If I the click on the PCManFM window, the text that I typed in the lxterminal appears and the command shows its output.

To log out I click on the menu icon on the bottom left in the lxpanel bar. I then have to press crtl-alt-f2 and get the second terminal, press ctrl-alt-f1 to get back to my LXDE session and the menu appears. I click on Logout, nothing happens, press ctrl-alt-f2, then ctrl-alt-f1 and the log out menu appears in the middle of the screen. I can then click on the log out button and I am logged out (I typically click on the shutdown option at that point).

I am attaching a screenshot that I took with my phone of the desktop right after I clicked on the PCManFM icon.

Comment 36 Steve 2018-12-23 05:12:46 UTC
(In reply to Phil from comment #35)
> Created attachment 1516290 [details]
> Screenshot when LXDE broken

Thanks for attaching the screenshot and for your detailed test cases.

> I never have see any amdgpu error messages in the log files. With either the
> 4.19.9 or the 4.19.10 kernels.

And thanks for confirming that you do NOT see the error message from Comment 34.

For the record, there are some differences in the hardware that could explain the differences in behavior:

chiguy:
Dec 15 09:31:56 fedora kernel: smpboot: CPU0: AMD A10-8700P Radeon R6, 10 Compute Cores 4C+6G (family: 0x15, model: 0x60, stepping: 0x1)
Dec 15 09:31:57 fedora kernel: [drm] initializing kernel modesetting (CARRIZO 0x1002:0x9874 0x103C:0x80AF 0xC5).

Phil:
Dec 21 10:09:48 mylaptop kernel: smpboot: CPU0: AMD A12-9700P RADEON R7, 10 COMPUTE CORES 4C+6G (family: 0x15, model: 0x65, stepping: 0x1)
Dec 21 10:09:49 mylaptop kernel: [drm] initializing kernel modesetting (CARRIZO 0x1002:0x9874 0x1028:0x0769 0xC9).

Comment 37 chiguy1256 2018-12-26 20:03:14 UTC
I still have the message in the journalctl.  However, I removed kernel 4.19.10.  I am currently running kernel 4.18.16 which doesn't break the xfce DE.

Comment 38 Steve 2018-12-26 21:01:35 UTC
(In reply to chiguy1256 from comment #37)
> I still have the message in the journalctl.  However, I removed kernel
> 4.19.10.  I am currently running kernel 4.18.16 which doesn't break the xfce
> DE.

Thanks for your update.

There is a 4.20 kernel available in the rawhide repo that may fix the problem.

Paul in Bug 1658845, Comment 3 says that he doesn't have any graphics issues with his AMD Carrizo GPU when running kernel 4.20.0-0.rc6.git1.1.fc30.x86_64.

If you don't mind testing a pre-release kernel, you can download the kernel packages from a Fedora rawhide mirror and install them with "dnf":

https://mirrors.kernel.org/fedora/development/rawhide/Everything/x86_64/os/Packages/k/

This is a minimal list of packages:

kernel-core-4.20.0-1.fc30.x86_64.rpm
kernel-modules-4.20.0-1.fc30.x86_64.rpm

Assuming you downloaded into an empty directory, install with:

# dnf update kernel*.rpm  # NB: These are package *files*.

Remove with:

# dnf remove kernel\*-4.20.0-1.fc30.x86_64  # NB: These are package *names*.

Tested in an F29 VM:

# uname -r
4.20.0-1.fc30.x86_64

# dnf -q list kernel\*-4.20.0-1.fc30.x86_64
Installed Packages
kernel-core.x86_64                   4.20.0-1.fc30                 @@commandline
kernel-modules.x86_64                4.20.0-1.fc30                 @@commandline

Comment 39 Steve 2018-12-26 21:40:02 UTC
(In reply to Steve from comment #38)
...
> If you don't mind testing a pre-release kernel, you can download the kernel
> packages from a Fedora rawhide mirror and install them with "dnf":
...

If you haven't worked with Fedora rawhide software before, it would probably be a good idea to read this first:

Releases/Rawhide
https://fedoraproject.org/wiki/Releases/Rawhide

Comment 40 Phil 2018-12-26 23:08:20 UTC
I am running kernel 4.20.0-1.fc30 and LXDE is working!!!

Comment 41 Steve 2018-12-27 03:48:43 UTC
(In reply to Phil from comment #40)
> I am running kernel 4.20.0-1.fc30 and LXDE is working!!!

That's great! However, we aren't done yet ... :-)

kernel-4.19.12-301.fc29 is in the pipeline:
https://apps.fedoraproject.org/packages/kernel/builds/

And there are several amdgpu commits in it:
https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/log/?h=v4.19.12&qt=grep&q=amdgpu

I can't tell whether they are relevant to this bug, but I would suggest removing 4.20.0-1.fc30 and running an older working kernel until the next F29 kernel is released, so you aren't running a hybrid system.

You can check for updates here:
https://bodhi.fedoraproject.org/updates/?search=kernel

Or run "dnf update kernel".

Comment 42 chiguy1256 2018-12-27 20:18:43 UTC
I think I will wait for the kernel-4.19.12-301.fc29 to come out and try at that time.  Thank you.

Comment 43 Steve 2018-12-28 17:59:45 UTC
(In reply to chiguy1256 from comment #42)
> I think I will wait for the kernel-4.19.12-301.fc29 to come out and try at
> that time.  Thank you.

kernel-4.19.12-301.fc29.x86_64 is available for testing:

# dnf update kernel --enablerepo=updates-testing

Post karma here -- include the bug number (Bug 1659711) in your report:

bugfix update in Fedora 29 for kernel and kernel-headers 
https://bodhi.fedoraproject.org/updates/FEDORA-2018-64a4d60839

I have tested 4.19.12-301 in a VM and on bare metal (Intel), and it boots as expected.

Comment 44 chiguy1256 2018-12-28 20:21:32 UTC
When I tried the dnf update kernel --enablerepo=updates-testing command, version 4.19.10-300 appeared in the dialog to install.  How do I get 4.19.12 to show up?  Please advise.  Thanks.

Comment 45 Steve 2018-12-29 02:49:09 UTC
(In reply to chiguy1256 from comment #44)
> When I tried the dnf update kernel --enablerepo=updates-testing command,
> version 4.19.10-300 appeared in the dialog to install.  How do I get 4.19.12
> to show up?  Please advise.  Thanks.

Try appending "--refresh":

# dnf update kernel --enablerepo=updates-testing --refresh

Comment 46 chiguy1256 2018-12-29 12:12:43 UTC
I did install kernel-4.19.12-301.  I rebooted my laptop and selected that as the kernel to load.  It still breaks my xfce de.  :(

Comment 47 Steve 2018-12-29 14:11:36 UTC
(In reply to chiguy1256 from comment #46)
> I did install kernel-4.19.12-301.  I rebooted my laptop and selected that as
> the kernel to load.  It still breaks my xfce de.  :(

That's disappointing. Please add negative karma here:

bugfix update in Fedora 29 for kernel and kernel-headers 
https://bodhi.fedoraproject.org/updates/FEDORA-2018-64a4d60839

Scroll to the end of that page.

Click the radio-button for "Is the update generally functional? (karma)" under the "-1" column.

In the "Comment & Feedback" box, say something like "Does not fix Bug 1659711."

NB: You will need to register and login to add karma. If you don't want to do that, use the radio-button for "Does the system's basic functionality continue to work after this update?"

Comment 48 Steve 2019-01-01 22:04:04 UTC
(In reply to chiguy1256 from comment #46)
> I did install kernel-4.19.12-301.  I rebooted my laptop and selected that as
> the kernel to load.  It still breaks my xfce de.  :(

Thanks for testing and for adding negative karma. Apparently, Bodhi doesn't generate a bug link while Bugzilla does.

https://bodhi.fedoraproject.org/updates/FEDORA-2018-64a4d60839#comment-880226

Comment 49 Steve 2019-01-24 00:20:59 UTC
kernel-4.20.3-200.fc29 has been pushed to stable:
https://bodhi.fedoraproject.org/updates/FEDORA-2019-5d537224ef

kernel-4.20.4-200.fc29 has been submitted for testing:
https://bodhi.fedoraproject.org/updates/FEDORA-2019-c042484003

Comment 50 chiguy1256 2019-01-24 00:24:34 UTC
I installed kernel update 4.20.3-200 and it does not break my de.  :)

My system does appear to take longer to boot though.  I need to take a look at the systemd-analyze.

Comment 51 chiguy1256 2019-01-24 00:28:17 UTC
Startup finished in 2.569s (kernel) + 4.973s (initrd) + 1min 8.365s (userspace) = 1min 15.908s
graphical.target reached after 1min 8.334s in userspace.

Comment 52 chiguy1256 2019-01-24 00:40:33 UTC
I guess it was just the first time boot to the new kernel that took so long.  I rebooted again and this time was a bit quicker.  More within normal range for my system.

Comment 53 Phil 2019-01-24 05:00:56 UTC
I also am able to boot and have LXDE work correctly with the new 4.20.3 kernel.

Comment 54 Jeremy Cline 2019-01-24 12:37:42 UTC
Thanks for letting us know


Note You need to log in before you can comment on or make changes to this bug.