Bug 166007 - dump does not dump ACLs -- excessive warnings
dump does not dump ACLs -- excessive warnings
Status: CLOSED DUPLICATE of bug 146567
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: dump (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-15 14:16 EDT by Damian Menscher
Modified: 2013-07-02 19:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 17:29:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Menscher 2005-08-15 14:16:32 EDT
Description of problem:
  DUMP: ACLs in inode #1720341 won't be dumped
  DUMP: ACLs in inode #1720342 won't be dumped
  DUMP: ACLs in inode #1720343 won't be dumped
  DUMP: ACLs in inode #1720344 won't be dumped
  DUMP: ACLs in inode #1720345 won't be dumped
  DUMP: ACLs in inode #1720346 won't be dumped
  DUMP: ACLs in inode #1720347 won't be dumped
  DUMP: ACLs in inode #1720348 won't be dumped


Version-Release number of selected component (if applicable):
dump-0.4b37-1

Steps to Reproduce:
Attempt to dump an ext3 filesystem on a machine with SElinux enabled

Actual results:
Impossible to see real output due to a warning for each of the million inodes.

Expected results:
Only real warnings should be given.  If you feel it's necessary to warn about
not dumping ACLs, warn once per filesystem, not once per inode.  Ideally, dump
should back these up.

Additional info:
This was reported previously in Bug 142525 and called a "feature".

Supposedly Stelian has a patch in QA now, so I'm hoping it can be incorporated
in the upcoming quarterly updates.

Marking severity "normal" since this is a high-profile, critical problem, but
there is a relatively easy workaround (grep -v).
Comment 1 Ben Levenson 2005-08-15 17:29:30 EDT

*** This bug has been marked as a duplicate of 146567 ***

Note You need to log in before you can comment on or make changes to this bug.