Bug 166051 - Sound not working on each power on
Sound not working on each power on
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 07:03 EDT by Abri
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-26 04:47:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abri 2005-08-16 07:03:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050730 Firefox/1.0.6

Description of problem:
After fresh install sound either works or is non-existant with constant flickering on speakers.

After kernel and driver update problem remains.  A reset does not resolve the issue but if one powers down the PC and starts it back up then sound sometimes works perfectly.

I am guessing this might be hardware initialization related?

My soundcard is an onboard via8237

Version-Release number of selected component (if applicable):
kernel: 2.6.12-1.1398_FC4 alsa-libs: 1.0.9rc4-2 alsa-kmdl: 1.0.9rf-39.rhfc4.at

How reproducible:
Always

Steps to Reproduce:
1.Poweron
2.Poweroff
3.repeat :)
  

Actual Results:  Sound either works or is non-existant with stuttering effect on speakers.

Expected Results:  Glorius sound should be pouring from my marvelous box :P

Additional info:

Can reproduce on other pc's with identical hardware as I am setting up a callcenter with pc's like this.
Comment 1 Rahul Sundaram 2005-08-16 07:09:03 EDT

Thank you for the report. Changing status to assigned
Comment 2 Martin Stransky 2005-08-22 09:44:40 EDT
You may try to mute some input channels, like Line-In, CD-in, Mic and so on...
Comment 3 Abri 2005-08-24 03:01:35 EDT
I have tried many different mixer settings.  In one instance the sound actually
started functioning but this was one isolated incident.

This happend after some very random mixer adjustments.  I tried the same on one
of the other pc's but to no avail.

I am aware that Fedora Core's sound does not always work out of the box without
some mixer adjustment.  I have, however tried almost all combinations of
settings on mixer but I have not be able to find a common point of failure.

Let me know if you need some more info.
Comment 4 Martin Stransky 2005-08-24 05:39:00 EDT
Could you attach output of 'aplay -l', lsmod and amixer?

Could you attach your /etc/asound.conf, /etc/modprobe.conf,
/etc/alsa/cards/aliases.conf?

Comment 5 Abri 2005-08-24 09:37:10 EDT
[root@lws1 lws1]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
  Subdevices: 4/4
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

-------------------------------------------------------------------------------

[root@lws1 lws1]# /sbin/lsmod
Module                  Size  Used by
parport_pc             28933  1
lp                     13001  0
parport                40585  2 parport_pc,lp
autofs4                29253  2
rfcomm                 42333  0
l2cap                  30661  5 rfcomm
bluetooth              56133  4 rfcomm,l2cap
sunrpc                167813  1
wlan_wep                5632  1
ipt_REJECT              5569  1
ipt_state               1857  2
ip_conntrack           41497  1 ipt_state
iptable_filter          2881  1
ip_tables              19393  3 ipt_REJECT,ipt_state,iptable_filter
video                  15941  0
button                  6609  0
battery                 9413  0
ac                      4805  0
md5                     4033  1
ipv6                  267841  8
uhci_hcd               35153  0
ehci_hcd               41037  0
shpchp                 94405  0
i2c_viapro              8017  0
i2c_core               21569  1 i2c_viapro
snd_via82xx            27584  1
gameport               18633  1 snd_via82xx
snd_ac97_codec         77820  1 snd_via82xx
snd_seq_dummy           3204  0
snd_seq_oss            37120  0
snd_seq_midi_event      7936  1 snd_seq_oss
snd_seq                60688  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            49312  0
snd_mixer_oss          17024  1 snd_pcm_oss
snd_pcm                96776  3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_timer              31492  2 snd_seq,snd_pcm
snd_page_alloc          7940  2 snd_via82xx,snd_pcm
snd_mpu401_uart         9088  1 snd_via82xx
snd_rawmidi            27936  1 snd_mpu401_uart
snd_seq_device          8204  4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd                    53892  14
snd_via82xx,snd_ac97_codec,snd_seq_dummy,snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              10913  1 snd
via_rhine              28361  0
mii                     5441  1 via_rhine
ath_pci                60452  0
ath_rate_onoe           8072  1 ath_pci
wlan                  109788  4 wlan_wep,ath_pci,ath_rate_onoe
ath_hal               147664  2 ath_pci
floppy                 65141  0
dm_snapshot            17413  0
dm_zero                 2113  0
dm_mirror              26157  0
ext3                  132681  2
jbd                    86233  1 ext3
dm_mod                 58101  6 dm_snapshot,dm_zero,dm_mirror

-------------------------------------------------------------------------------

[root@lws1 lws1]# amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Simple mixer control 'Master Mono',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 14 [45%] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 20 [65%] [on]
  Front Right: Playback 20 [65%] [on]
Simple mixer control '3D Control - Center',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Limits: 0 - 15
  Mono: 10 [67%]
Simple mixer control '3D Control - Depth',0
  Capabilities: volume volume-joined
  Playback channels: Mono
  Limits: 0 - 15
  Mono: 9 [60%]
Simple mixer control '3D Control - Switch',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on]
  Front Right: Playback 23 [74%] [on]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 15 [48%] [on]
  Front Right: Playback 15 [48%] [on]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 16 [52%] [on]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 31
  Mono: Playback 13 [42%] [on]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 0 [0%] [off] Capture [off]
  Front Right: Playback 0 [0%] [off] Capture [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 23 [74%] [on] Capture [off]
  Front Right: Playback 23 [74%] [on] Capture [off]
Simple mixer control 'Mic',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 1 [3%] [on]
  Front Left: Capture [on]
  Front Right: Capture [on]
Simple mixer control 'Mic Boost (+20dB)',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Mic Select',0
  Capabilities:
  Mono:
Simple mixer control 'Video',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Phone',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined cswitch
cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Mono
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono: Playback 21 [68%] [on]
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'PC Speaker',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 15
  Mono: Playback 4 [27%] [on]
Simple mixer control 'Aux',0
  Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-joined
cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Front Left: Playback 14 [45%] [on] Capture [off]
  Front Right: Playback 14 [45%] [on] Capture [off]
Simple mixer control 'Mono Output Select',0
  Capabilities:
  Mono:
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 15 [100%] [on]
  Front Right: Capture 15 [100%] [on]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'Mix Mono',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Front Left - Front Right
  Front Left: Capture [off]
  Front Right: Capture [off]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Input Source Select',0
  Capabilities:
  Mono:
Simple mixer control 'Input Source Select',1
  Capabilities:
  Mono:

-------------------------------------------------------------------------------

[root@lws1 lws1]# cat /etc/asound.conf
# Generated by system-config-soundcard, do not edit by hand
defaults.pcm.card 0
defaults.pcm.card 0

-------------------------------------------------------------------------------

[root@lws1 lws1]# cat /etc/modprobe.conf
alias eth0 via-rhine
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
options snd-via82xx index=0
remove snd-via82xx { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-via82xx
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias ath0 ath_pci

-------------------------------------------------------------------------------

[root@lws1 lws1]# cat /etc/alsa/cards/aliases.conf
#
#  Define aliases for various drivers
#

YMF724 cards.YMF744
YMF724F cards.YMF744
YMF740 cards.YMF744
YMF740C cards.YMF744
YMF754 cards.YMF744
CMIPCI cards.CMI8338
CMI8738 cards.CMI8338
CMI8738-SWIEC cards.CMI8338-SWIEC
CMI8738-MC4 cards.CMI8738-MC6
'E-mu APS' cards.EMU10K1
'GUS MAX' cards.GUS
'GUS ACE' cards.GUS
'GUS Extreme' cards.GUS
'AMD InterWave' cards.GUS
'Dynasonic 3-D' cards.GUS
'InterWave STB' cards.GUS
au8810 cards.AU8810
au8820 cards.AU8820
au8830 cards.AU8830
Prodigy71 cards.Aureon71
VIA82XX-MODEM cards.ICH-MODEM
'MPU-401 UART' cards.MPU-401
'VX222/Old' cards.VX222
'VX222/v2' cards.VX222
'VX222/Mic' cards.VX222
'CMI8330/C3D' cards.CMI8330
'SB AWE' cards.SBAWE
'SB Pro' cards.SBPro
'PMac Burgundy' cards.PMac
'PMac DACA' cards.PMac
'PMac Tumbler' cards.PMac
'PMac Snapper' cards.PMac
'PMac Screamer' cards.PMac
'PMac AWACS' cards.PMac
'PMac Toonie' cards.PMacToonie
'USB US-X2Y' cards.US-X2Y
'Serial MIDI' cards.SerialMIDI
'Prodif Plus' cards.ProdifPlus
ESM1 cards.ES1968
ES1978 cards.ES1968
Allegro cards.Maestro3
Canyon3D-2 cards.Maestro3
Azalia cards.HDA-Intel
aaci-pl041 cards.AACI

<confdir:pcm/default.conf>
<confdir:pcm/dmix.conf>
<confdir:pcm/dsnoop.conf>
Comment 6 Martin Stransky 2005-08-29 06:29:45 EDT
Could you please try to check the 'External Amplifier' switch? You can use
"alsamixer" command line tool. I think it's a dupe of #166153.
Comment 7 Abri 2005-08-31 03:51:40 EDT
Toggling the External amplifier has no effect.

I am noticing that the problem becomes more difficult to reproduce. I had to
hard reboot one pc several times to get the sound into its non-functional state.
 Probably its just coincidence.
Comment 8 Abri 2005-08-31 06:12:40 EDT
Just did a fresh install on one of the spare pc's.  It's sound was
non-fucntional on the first bootup so I proceeded to toggle the external
amplifier switch in the mixer.

This did not help and neither did any other adjustments.

The sound started working working on the next poweron.  This seems to be the
case on most subsequent powerons but I am deploying this setup to about 20-50 pc
so I want it to work as often as possible.

Hope this helps.
Comment 9 Abri 2005-09-03 08:37:47 EDT
Noticed something on one of the PC's with sound working:

A sharp sound while recording tends to cause sound to stop working.

Recording seems unaffected as far as I can tell, IE even a pc with broken output
seems to be able to record sound.

Comment 10 Abri 2005-09-27 06:48:40 EDT
Is this bug still active?
Comment 11 Martin Stransky 2005-10-07 08:06:57 EDT
Could you please compare output of "amixer" when sound works and when it
doesn't? If there isn't any diference, the problem will be somewhere in driver.
Comment 12 Abri 2005-10-07 08:56:14 EDT
Unfortunately my company is no longer providing the services, which required me
to get the sound working on those pc's.  As a consequence I no longer have
access to them.  

I will try to provide information if it ever becomes possible again.

Thanks for all the trouble though.
Comment 13 Martin Stransky 2005-10-07 09:02:10 EDT
Don't worry with it, I think it's a problem in 1.0.9 driver and it will be fixed
in some new version, ALSA upstream is very fast...

Note You need to log in before you can comment on or make changes to this bug.