Bug 1660560 - ovirt Console : internal error: cannot find character device <null>
Summary: ovirt Console : internal error: cannot find character device <null>
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-ansible-roles
Classification: oVirt
Component: hosted-engine-setup
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ovirt-4.3.1
: ---
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
Tahlia Richardson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-18 15:51 UTC by Slx
Modified: 2019-03-01 10:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-01 10:20:20 UTC
oVirt Team: Integration
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github oVirt ovirt-ansible-hosted-engine-setup pull 111 'None' 'closed' 'another try with serial console' 2019-11-28 20:17:09 UTC

Description Slx 2018-12-18 15:51:18 UTC
This bug might be the same than https://bugzilla.redhat.com/show_bug.cgi?id=1561964 (but it should be corrected in the used version)

Description of problem:
When you try to connect to the engine with console using "hosted-engine --console" (or virsh console HostedEngine) you get the following error : " :internal error: cannot find character device <null>"




Version-Release number of selected component (if applicable):
4.2.7.5-1.el7

How reproducible:
100%


Steps to Reproduce:
1. hosted-engine --console

Actual results:
2. error :internal error: cannot find character device <null>


Expected results:
connection



Additional info:

workaround ? : 
there is similar report of this bug in previous ( https://bugzilla.redhat.com/show_bug.cgi?id=1561964 ) 
and in the documentation (but not for ovirt) like this one :
https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/6/html/virtualization_host_configuration_and_guest_installation_guide/app_domain_console

For what i know (but i might be wrong), the documentation does not present a possible workaround for ovirt for this problem since you can only edit the grub when the vm is shutdown, and the storage does not exist anymore when the vm is down.

i'm not sure too than the "virsh edit" command can be saved after the vm is restarted

Comment 1 Sandro Bonazzola 2019-01-09 09:30:15 UTC
We changed the way we save the OVF xml by doing it every minute during the initial deployment, this should workaround this issue as well.

Comment 2 Nikolai Sednev 2019-01-20 13:47:06 UTC
alma03 ~]# hosted-engine --console
The engine VM is running on this host
Connected to domain HostedEngine
Escape character is ^]
error: internal error: cannot find character device <null>

Still getting this issue reproduced on latest 4.3:
ovirt-hosted-engine-setup-2.3.2-1.el7ev.noarch
ovirt-hosted-engine-ha-2.3.0-1.el7ev.noarch
rhvm-appliance-4.3-20190115.0.el7.x86_64
Linux 3.10.0-957.1.3.el7.x86_64 #1 SMP Thu Nov 15 17:36:42 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.6 (Maipo)

Enable VirtIO serial console option in UI is not marked for engine after its cleanly deployed.
Tested over NFS.

Moving back to assigned.

Comment 3 Sandro Bonazzola 2019-01-21 08:28:33 UTC
re-targeting to 4.3.1 since this BZ has not been proposed as blocker for 4.3.0.
If you think this bug should block 4.3.0 please re-target and set blocker flag.

Comment 4 Nikolai Sednev 2019-02-26 13:23:57 UTC
Works for me on these components:
virt-ansible-engine-setup-1.1.8-1.el7ev.noarch
ovirt-ansible-repositories-1.1.5-1.el7ev.noarch
ansible-2.7.8-1.el7ae.noarch
rhvm-appliance-4.3-20190220.2.el7.x86_64
Red Hat Enterprise Linux Server release 7.6 (Maipo)
Linux 3.10.0-957.5.1.el7.x86_64 #1 SMP Wed Dec 19 10:46:58 EST 2018 x86_64 x86_64 x86_64 GNU/Linux

@alma03 ~]# hosted-engine --console
The engine VM is running on this host
Escape character is ^]

Red Hat Enterprise Linux Server 7.6 (Maipo)
Kernel 3.10.0-957.5.1.el7.x86_64 on an x86_64

nsednev-he-1 login: root
Password: 
Last login: Tue Feb 26 15:12:42 on ttyS0
[root@nsednev-he-1 ~]# 
[root@nsednev-he-1 ~]# 
[root@nsednev-he-1 ~]# 
[root@nsednev-he-1 ~]# exit
logout

Red Hat Enterprise Linux Server 7.6 (Maipo)
Kernel 3.10.0-957.5.1.el7.x86_64 on an x86_64

nsednev-he-1 login: 
Red Hat Enterprise Linux Server 7.6 (Maipo)
Kernel 3.10.0-957.5.1.el7.x86_64 on an x86_64

nsednev-he-1 login: [root@alma03 ~]# 
[root@alma03 ~]# 

In UI "Serial Consol:" tab is properly marked now in it's "Enable VirtIO serial console" checkbox.

Comment 5 Sandro Bonazzola 2019-03-01 10:20:20 UTC
This bugzilla is included in oVirt 4.3.1 release, published on February 28th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.