Bug 1660682 - xpdfreader - new printing routine error
Summary: xpdfreader - new printing routine error
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: xpdf
Version: 30
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-19 01:16 UTC by Luigi Cantoni
Modified: 2019-11-14 00:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description Luigi Cantoni 2018-12-19 01:16:21 UTC
Description of problem:
When printing in XpdfReader (Xpdf PDF Viewer) it appear to be not obeying directives for trays, pages (possible others) etc
The printing routine appears to be a new version.

Version-Release number of selected component (if applicable):
xpdf.x86_64                        1:4.00-8.fc29                         @fedora

How reproducible:
100%

Steps to Reproduce:
1. open a pdf document using xpdfreader
2. select print
3. select a printer
4. select a particular tray
5. select a page to print
6. select print

Actual results:
Default tray selected
All pages in document printed

Expected results:
Should select particular tray
Should only print selected page

Additional info:
I have not tested other options.
I have rebooted and also checked for updates (none available).
Problem is still there.
I have used evince (Document Viewer) and it works fine selecting tray/page to print.
It worked fine before this latest update.

If wanted I am happy to downgrade to an earlier version to confirm that version worked fine, just advise which one you would like tested.

Comment 1 Luigi Cantoni 2019-02-05 04:42:01 UTC
I can confirm that this error appears to be independent of printer and tray.
Just the page selection appears to ignore the request for a particular page and prints the whole document.
I confirm no updates yet.
xpdf.x86_64                        1:4.00-8.fc29                         @fedora
Tried downgrading to i686 version. Same problem.
Workaround: Use the page to page section and that does appear to work.

Comment 2 Ben Cotton 2019-10-31 20:01:13 UTC
This message is a reminder that Fedora 29 is nearing its end of life.
Fedora will stop maintaining and issuing updates for Fedora 29 on 2019-11-26.
It is Fedora's policy to close all bug reports from releases that are no longer
maintained. At that time this bug will be closed as EOL if it remains open with a
Fedora 'version' of '29'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 29 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Luigi Cantoni 2019-11-01 04:59:02 UTC
Just tested the version below and Page appears fixed but tray still appears to fail.
I have not tested any other options as these are the two most common ones.

Installed Packages
xpdf.x86_64                        1:4.02-1.fc30

Comment 4 Tom "spot" Callaway 2019-11-13 17:14:30 UTC
This is difficult for me to troubleshoot, since I do not have access to any printers with multiple trays.

Comment 5 Luigi Cantoni 2019-11-14 00:34:00 UTC
Just confirmed my package is:

Installed Packages
xpdf.x86_64                        1:4.02-1.fc30

Also as noted above the select pages also fails. I am 90% sure all options are failing so it will almost certainly be a general problem.

Just create up a simple .pdf file with say 3 pages and print page 2. It fails and prints all 3 pages.


Note You need to log in before you can comment on or make changes to this bug.