Bug 166089 - kickstart requires comps
kickstart requires comps
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
4
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 16:25 EDT by Sander Hoentjen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 12:12:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sander Hoentjen 2005-08-16 16:25:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050729 Fedora/1.1-0.2.5.deerpark.alpha2 Firefox/1.0+

Description of problem:
I installed system-config-kickstart through yum, then I tried to launch it through the menu. Nothing seemed to happen so I tried with the console and got the following error:
I/O warning : failed to load external entity "/usr/share/comps/i386/comps.xml"
Could not start because there is no /usr/share/comps/i386/comps.xml file.
Please make sure the comps package is installed.
After installing the comps package (yum install comps) all is fine.
So I guess system-config-kickstart should require comps?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 Chris Lumens 2005-08-19 11:43:14 EDT
I think the bigger question here is why the comps package was not installed.  Do
you remember what sort of install you did?
Comment 2 Sander Hoentjen 2005-08-22 05:59:17 EDT
I am not 100% sure but I think I did a pxe boot followed by an ftp install of FC4
Comment 3 Chris Lumens 2005-09-23 12:12:02 EDT
You should grab the comps rpm from one of the Fedora mirrors (it should have a
name similar to comps-4-0.20050606.i386.rpm) and install it onto your machine. 
I don't know why it wouldn't have been installed to begin with.  For the future,
we have eliminated the comps RPM as part of the ongoing package selection work,
so s-c-kickstart will have to change how it lists packages.

I am closing this bug as WORKSFORME only because I cannot get the comps package
to be missing.  If you still experience problems even after installing that
package, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.