Bug 166094 - Completion for subversion doesn't work properly for non-english locales
Completion for subversion doesn't work properly for non-english locales
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: zsh (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-16 16:50 EDT by Thomas Moschny
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-16 18:13:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch: Always call svn/svnadmin with LC_MESSAGES=C. (2.97 KB, patch)
2005-08-16 16:59 EDT, Thomas Moschny
no flags Details | Diff

  None (edit)
Description Thomas Moschny 2005-08-16 16:50:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.2 (like Gecko)

Description of problem:
The completion script /usr/share/zsh/4.2.1/functions/_subversion parses the  
output of 'svn help' and 'svnadmin help'. In an environment with  
LC_MESSAGES != C or en_US or similar, parsing will fail.  

Version-Release number of selected component (if applicable):
zsh-4.2.1-2

How reproducible:
Always

Steps to Reproduce:
1. Set LC_MESSAGES e.g. to de_DE.  
2. Start a new zsh, verify the value of LC_MESSAGES with the 'locale' cmd.  
3. At the prompt, enter svn <SPACE> and press <TAB>.  
  

Actual Results:  Strange completion suggestions are displayed. 

Additional info:
Comment 1 Thomas Moschny 2005-08-16 16:59:46 EDT
Created attachment 117803 [details]
Proposed patch: Always call svn/svnadmin with LC_MESSAGES=C.
Comment 2 Christopher Aillon 2006-09-16 18:13:51 EDT
This seems to be fixed in the current version in rawhide.  The code sets
LC_ALL=C before calling any svn commands.

Note You need to log in before you can comment on or make changes to this bug.