Bug 16614 - possible shadow password issue with initial user account
possible shadow password issue with initial user account
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-19 19:54 EDT by Need Real Name
Modified: 2007-03-26 23:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-31 15:55:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-19 19:54:44 EDT
I installed a getty on a serial port and discovered I could log in without
giving my password. I use shadow passwords and the getties are compiled
correctly. I created a new account and password checking on it worked fine. 

Next I changed my password from the console and found that the password
issue was corrected. The account I use was created during the install
process and I suspect that the shadow password was not correctly configured
then, since getties without shadow support give the same symptoms.
Comment 1 Brock Organ 2000-08-20 13:35:42 EDT
was your original install of 6.2 via kickstart ...? If so, this is a known issue
and can be resolved by downloading and using newer disk images ...
Comment 2 Need Real Name 2000-08-21 13:27:40 EDT
I did the install in expert mode (i.e. not in kickstart).
Comment 3 Brock Organ 2000-08-22 14:51:20 EDT
hmmm ... I could not reproduce this problem:

I did a minimum (+mgetty & minicom pkgs) install of 6.2, and ran minicom on a
remote system over ttyS0 @ 19200 8n1 ... locally I ran the mgetty program to
fetch the login through minicom:

% mgetty -r -s 19200 /dev/ttyS0

and then was able to login using a user account created during the install, and
the password was asked (both for root and non-root user) ...

Red Hat Linux release 6.2 (Zoot)
Kernel 2.2.14-5.0 on an i686


test168.test.redhat.com login: foobar
Password: 
Last login: Tue Aug 22 18:46:51 on tty1
[foobar@test168 foobar]$ 

Are these steps similar to what you did on your system ...?  Do you have the
same problem reproducably on that system (or another :) ) ...?
Comment 4 Need Real Name 2000-08-22 16:05:49 EDT
I am not too keen on trying to reproduce it, but I will keep an eye on it when
installing an upgrade.

It is possible I used the 'text expert' mode, maybe that makes a difference?
With the 'kickstart' install, was the 'x' missing in the passwd file for the
initial account?
Comment 5 Brock Organ 2000-08-31 15:55:20 EDT
hmmm ... I haven't seen this problem in 6.2 or occuring during the Winston test
campaign (our next release), and so I will close this (I'm not sure what you may
have tickled to get the above behavior :( ), but please reopen if this continues
to recur or if you have any other information to help reproduce this ... thanks
for the report!

Note You need to log in before you can comment on or make changes to this bug.